求一个字符串中最长的连续出现的字符,输出该字符及其出现次数,字符串中无空白字符(空格、回车和 tab𝑡𝑎𝑏),如果这样的字符不止一个,则输出第一个。
输入样例:
2
aaaaabbbbbcccccccdddddddddd
abcdefghigk
输出样例:
d 10
a 1
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int N = sc.nextInt(); // 读取测试数据组数
sc.nextLine(); // 跳过行尾剩余部分
for (int test = 0; test < N; test++) {
String s = sc.nextLine();
char maxChar = s.charAt(0);
int maxCount = 1;
int currentCount = 1;
for (int i = 1; i < s.length(); i++) {
if (s.charAt(i) == s.charAt(i - 1)) {
// 如果当前字符与前一个字符相同,增加计数
currentCount++;
} else {
// 否则,检查之前的计数是否是最大的
if (currentCount > maxCount) {
maxCount = currentCount;
maxChar = s.charAt(i - 1);
}
// 重置当前计数
currentCount = 1;
}
}
// 检查字符串末尾的连续字符
if (currentCount > maxCount) {
maxCount = currentCount;
maxChar = s.charAt(s.length() - 1);
}
// 输出最长连续字符及其次数
System.out.println(maxChar + " " + maxCount);
}
sc.close();
}
}