hdu AreYouBusy



Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
 

Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
 

Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
 

Sample Input
  
  
3 3 2 1 2 5 3 8 2 0 1 0 2 1 3 2 4 3 2 1 1 1 3 4 2 1 2 5 3 8 2 0 1 1 2 8 3 2 4 4 2 1 1 1 1 1 1 0 2 1 5 3 2 0 1 0 2 1 2 0 2 2 1 1 2 0 3 2 2 1 2 1 1 5 2 8 3 2 3 8 4 9 5 10
 

Sample Output
  
  
5 13 -1 -1



题意:有n份工作,T时间,每份工作有m件事情,s表示该工作性质,0表示至少做一件,1表示至多做一件,2表示随便做多少件,给出每件事情所需的时间和会得到的愉悦度,输出最大愉悦度,如果无法满足条件则输出-1





#include<iostream>
#include<cmath>
#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<string.h>
#define INF 1e8
using namespace std;
int dp[900][500];
int vis[30000];
int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
       for(int i=1;i<=n;i++)
       {
           int nn,s;
           scanf("%d%d",&nn,&s);
           if(s==0)//至少做一件
           {
               for(int j=0;j<=m;j++) dp[j][i]=-INF;
               for(int j=1;j<=nn;j++)
               {
                   int v,c;
                   scanf("%d%d",&v,&c);
                  for(int k=m;k>=v;k--)
                  {
                      dp[k][i]=max(dp[k-v][i-1]+c,max(dp[k-v][i]+c,dp[k][i]));//是否做了一件,本事情第一个做
                  }
               }

           }
           else if(s==1)//至多做一件
           {
               for(int j=0;j<=m;j++)
                dp[j][i]=dp[j][i-1];
               for(int j=1;j<=nn;j++)
               {
                   int v,c;
                   scanf("%d%d",&v,&c);
                  for(int k=m;k>=v;k--)
                  {
                      dp[k][i]=max(dp[k][i],dp[k-v][i-1]+c);//做与不做比较
                  }
               }
           }
           else if(s==2)//随便做
           {
               for(int j=0;j<=m;j++)
                dp[j][i]=dp[j][i-1];
               for(int j=1;j<=nn;j++)
               {
                   int v,c;
                   scanf("%d%d",&v,&c);
                  for(int k=m;k>=v;k--)
                  {
                      dp[k][i]=max(dp[k][i],dp[k-v][i]+c);
                  }
               }
           }
       }
    printf("%d\n",max(-1,dp[m][n]));
    }
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值