Description
定义
S
(
x
)
S(x)
S(x)为
x
x
x的各个位数字从小到大排形成的数,前导
0
0
0忽略,求
∑
i
=
1
n
S
(
i
)
\sum_{i=1}^nS(i)
∑i=1nS(i)。
Sample Input
21
Sample Output
195
首先你考虑把每一种数字拆开来考虑贡献。
然后你会发现这样的转移是会做到
O
(
100
n
3
)
O(100n^3)
O(100n3)的。。。
因为你要存一个同样的值有多少个,比他小的值有多少个才能计算贡献。
然后就有这样一种方法。
你可以考虑将计算答案的方式改为:
假设有j个数大于等于你现在枚举的数,那么你对于答案的贡献就是1111…(j个1)。
这个很好懂,你举个例子就好了。
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const LL mod = 1e9 + 7;
int _min(int x, int y) {return x < y ? x : y;}
int _max(int x, int y) {return x > y ? x : y;}
int read() {
int s = 0, f = 1; char ch = getchar();
while(ch < '0' || ch > '9') {if(ch == '-') f = -1; ch = getchar();}
while(ch >= '0' && ch <= '9') s = s * 10 + ch - '0', ch = getchar();
return s * f;
}
char ss[710];
int lt[710];
LL f[710][710][10][2], hh[710];
LL dfs(int x, int ov, int now, int limit) {
if(x == 0) return hh[ov];
if(f[x][ov][now][limit] != -1) return f[x][ov][now][limit];
int up = 9; LL ans = 0;
if(limit == 1) up = lt[x];
for(int i = 0; i <= up; i++) {
int ff = limit;
if(i != up) ff = 0;
(ans += dfs(x - 1, ov + (i >= now), now, ff)) %= mod;
} f[x][ov][now][limit] = ans;
return ans;
}
int main() {
scanf("%s", ss + 1);
int len = strlen(ss + 1);
for(int i = 1; i <= len; i++) lt[len - i + 1] = ss[i] - '0';
hh[1] = 1; for(int i = 2; i <= len; i++) hh[i] = hh[i - 1] * 10LL % mod;
for(int i = 1; i <= len; i++) (hh[i] += hh[i - 1]) %= mod;
LL ans = 0;
memset(f, -1, sizeof(f));
for(int i = 1; i <= 9; i++) {
(ans += dfs(len, 0, i, 1)) %= mod;
} printf("%lld\n", ans);
return 0;
}