POJ 1064 切绳子 二分搜索求一个可行解

题目连接

http://poj.org/problem?id=1064

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).

Sample Input

4
11
4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Hint

题意

给出几段绳子,并给定要切割的段数,然后求能切割出的最大长度

题解

二分搜索找值,并判断该值是大了还是小了,相应地改变ub与lb的值

代码

/*****************************************************************
                    date:2016.3.28 time:23:37
******************************************************************/
#include<iostream>
  #include<cstdio>
  #include<cstring>
  #include<string>
  #include<cmath>
  #include<string>
 #include<cctype>
  #include<algorithm>
  #include<vector>
using namespace std;
#define max 1000
typedef pair<int,int>p;
#define INF  1e9+7
#define ll long long
#define eps 1e-6
int n=0,k=0;
double a[10010];
bool c(double x){
    int sum=0;
    for (int i = 0; i < n; ++i)
    {
        sum+=(int)(a[i]/x);//这里坑死了,应该是整体转换而不是(int)a[i]/x
    }
    return sum>=k;
}
int main(int argc, char const *argv[])
{
    cin>>n>>k;
    for (int i = 0; i < n; ++i)
    {
        cin>>a[i];
    }
    double lb=0,ub=INF,mid;
    for (int i = 0; i < 100; ++i)
    {
        mid=(lb+ub)/2;
        if(c(mid))lb=mid;
        else ub=mid;
    }
    printf("%.2f\n",floor(ub*100)/100);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值