POJ 3258 小牛过河 二分搜索最大的最小值

题目连接

http://poj.org/problem?id=3258

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

去掉2 和 14 就是样列的解

题意

给你一个数,从这已有的石块中去掉这么多块石头,问怎样去掉可以使去掉之后任意两个相邻石头之间的距离的最小值最大(好绕口…….就是让两个最小距离的石块的值最大。例如 2 5 10 d(min)=5-2=3让这个值与其他的值比较,尽可以能的大)

题解

二分从最大值INF开始找,然后判断这个值是否仍满足去掉x块石头后的距离,注意去石头时的方法,有点像尺取法,一头一尾地确定,以剩下的石头为条件

代码

#include<iostream>
  #include<cstdio>
  #include<cstring>
  #include<string>
  #include<cmath>
  #include<string>
 #include<cctype>
  #include<algorithm>
  #include<vector>
#define max 1000
#define INF  1e9+7
#define ll long long
#define eps 1e-6
using namespace std;
typedef pair<int,int> p;
int N[50100];
int l,n,m;
bool rock(int x){
    int num=n-m;
    int last=0;
    for (int i = 1; i <=num ; ++i)
    {   int cur=last+1;
         while (cur<=n&&N[cur]-N[last]<x)
         {  
             cur++;
         }
         if(cur>n)return false;
         last=cur; 
    }
    return true;
}
int main(int argc, char const *argv[])
{
    cin>>l>>n>>m;
    memset(N,0,sizeof(N));
    N[0]=0;
    N[n+1]=l;
    for (int i = 1; i <=n; ++i)
    {
        cin>>N[i];
    }
    sort(N,N+n+1);
    if(n==m){
        printf("%d",l);
        return 0;
    }
    int mid,ub=l,lb=0;
   for(int i=0;i<100;i++){
   {   mid=(ub+lb)/2;
        if(rock(mid)){lb=mid;
            }
        else ub=mid;

    }}
    printf("%d\n",lb );
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值