POJ 3321 Apple Tree
线段树与树状数组 H题
There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.
The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.
The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?
Input
The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning
Output
For every inquiry, output the correspond answer per line.
Sample Input
3
1 2
1 3
3
Q 1
C 2
Q 1
Sample Output
3
2
题意:一棵树有n个结点,编号1~n,1是根节点,有n-1条边,能执行两种操作:①“C x” 对x结点,如果是空结点加上一个苹果(+1),非空节点拿掉一个苹果(-1)②“Q x” 查询x结点的子树有多少苹果,输出。
思路:所以需要我们自己来重新给结点编号。这里利用dfs对树遍历一遍,使用一个时间戳(从1开始),在遍历一个结点开始和结束分别记录时间戳s[i],e[i],能够发现s[i]即为结点i的新编号,s[i]~e[i]即为结点i的管辖范围(就是以i为根的子数的所有结点编号所在区间)。
然后就可以利用树状数组来解决剩下的问题了,对单点进行修改,对一个结点的子树进行查询,结果就是query(e[i])-query(s[i]-1)。
#include<cstdio>
using namespace std;
const int maxn=100005;
struct node{
int v,next;
}edge[maxn<<1];
int head[maxn],tr[maxn],s[maxn],e[maxn];
bool vis[maxn],a[maxn];
int n,m,cnt,tim;
void add(int u,int v){
edge[cnt].v=v;
edge[cnt].next=head[u];
head[u]=cnt++;
}
void dfs(int p){
s[p]=++tim;
vis[p]=1;
for(int i=head[p];i!=-1;i=edge[i].next){
if(vis[edge[i].v])
continue;
dfs(edge[i].v);
}
e[p]=tim;
}
int lowbit(int x){
return x&(-x);
}
void update(int x,int num){
while(x<=n){
tr[x]+=num;
x+=lowbit(x);
}
}
int query(int x){
int ans=0;
while(x>0){
ans+=tr[x];
x-=lowbit(x);
}
return ans;
}
int main(){
scanf("%d",&n);
for(int i=1;i<=n;++i){
head[i]=-1;
a[i]=1;
update(i,1);
}
for(int i=1;i<n;++i){
int u,v;
scanf("%d%d",&u,&v);
add(u,v);
add(v,u);
}
dfs(1);
scanf("%d",&m);
char c;
int t;
while(m--){
scanf(" %c%d",&c,&t);
if(c=='C'){
if(a[t]){
a[t]=0;
update(s[t],-1);
}
else{
a[t]=1;
update(s[t],1);
}
}
else{
printf("%d\n",query(e[t])-query(s[t]-1));
}
}
return 0;
}