A1025. PAT Ranking (25)

1.题目描述

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

2.解题过程

本题利用结构体和sort排序函数进行处理。
代码如下:

/*A1025*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define NUM 15
struct Student{
    char id[NUM];
    int score;
    int finRank;
    int locaNum;
    int locaRank;
}stu[30010];
bool cmp(Student A,Student B){
    if(A.score!=B.score)    return A.score>B.score;
    else    return strcmp(A.id,B.id)<0;
}
int main(){
    int n;
    int sumNum = 0;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        int m;
        scanf("%d",&m);
        for(int j=0;j<m;j++){
            scanf("%s %d",&stu[sumNum].id,&stu[sumNum].score);
            stu[sumNum].locaNum = i+1;
            sumNum++;
        }
        sort(stu+sumNum-m,stu+sumNum,cmp);  //地区排序
        stu[sumNum-m].locaRank = 1;
        for(int j=sumNum-m+1;j<sumNum;j++){
            if(stu[j].score==stu[j-1].score)
                stu[j].locaRank = stu[j-1].locaRank;
            else
                stu[j].locaRank = j-(sumNum-m)+1;
        }
    }
    //全排序
    sort(stu,stu+sumNum,cmp);
    stu[0].finRank = 1;
    for(int i=1;i<sumNum;i++){
        if(stu[i].score==stu[i-1].score)
            stu[i].finRank = stu[i-1].finRank;
        else
            stu[i].finRank = i+1;
    }
    printf("%d\n",sumNum);
    for(int i=0;i<sumNum;i++){
        printf("%s %d %d %d\n",stu[i].id,stu[i].finRank,stu[i].locaNum,stu[i].locaRank);
    }
    return 0;
}

3.基础知识回顾

主要复习一下C语言中的库函数qsort和C++中的库函数sort。因为解题用的sort,因此以sort为例。qsort还涉及指针用法且写法也不如sort简洁。
1)sort函数使用需要加头文件#include<algorithm> 以及命名空间 using namespace std;
2)函数形式(首元素地址(必填),(尾元素地址的下一位)(必填),比较函数(非必填))
注意是尾元素地址的下一位,还有比较函数默认为递增。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值