最长子序列

             

                                          Longest Ordered Subsequence

描述

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).


Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
输入
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
输出

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.


样例输入
7
1 7 3 5 9 4 8
样例输出

4


/****************************
****最长有序子序列
****使用动态规划法
****time:2013.12.8
****by xiaomo   
*****************************/
#include<iostream>
#include<time.h>
#include<vector>
using namespace std;                                           

void LongestOrderedSeq(int n,int *a)
{
	int *bp=new int[n];                      //存放最大长度的数组
    int *pos=new int[n];                     //存放最长有序子序列的路径
	memset(bp,0,sizeof(int)*n);              //从bp出事地址开始初始化sizeof(int)*n个字节为1;
	memset(pos,-1,sizeof(int)*n);            //初始化路径数组
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<i;j++)
		{
    //计算f[i]时,bp[i]=max(bp[j]+1) ,(其中,a[i]>a[j],i>j>=0),
    //意思是以a[i]为结尾,找出在a[i]前比a[i]小的数据中以该数据为结尾的最大有序子
    //序列长度max(bp[j]),则以a[i]结尾的最大有序子序列长度为max(bp[j])+1
			if(a[i]>a[j]&&bp[j]+1>bp[i])     //动态规划的关键
			{
				bp[i]=bp[j]+1;               //改变最大长度
				pos[i]=j;                    //记录位置
			}
		}
	}
	int max=bp[0];
	int position=0;
	for(int i=1;i<n;i++)        //找出最长的一个和它所在的位置
	{
		if(max<bp[i])
		{
			max=bp[i];
			position=i;
		}
	}
	cout<<max+1<<" "<<position<<endl;
	vector<int> vec;
	while(position!=-1)
	{
		vec.push_back(a[position]);
		position=pos[position];
	}
    cout<<"The priority path is :";
	for(int i=vec.size()-1;i>=0;i--)
		cout<<vec.at(i)<<" ";
	cout<<endl;
	delete[] bp;
	bp=NULL;
	delete[] pos;
	pos=NULL;
}

int main()
{
	cout<<"———————————最长有序子序列———————————————\n";
	int flag=1;
	while(flag==1)
	{
		int n;
		cout<<"Please input the size of array:";
        cin>>n;
        int *a=new int[n];
        cout<<"Please input the elements of the array:";
        for(int i=0;i<n;i++)
			cin>>a[i];
        double startTime,endTime;
        startTime=clock();
        LongestOrderedSeq(n,a);
        delete[] a;
		a=NULL;
        endTime=clock();
        cout<<"The program running time is "<<(endTime-startTime)/CLOCKS_PER_SEC<<"s.\n";
        cout<<"__________________________________________________________________\n";
        cout<<"Whether continue the game,please input your choice(1->yes,other->no):";
        cin>>flag;
	}
	cout<<"———————————最长有序子序列———————————————\n";
	return 0;
} 





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值