07-图6 旅游规划(25 分)

有了一张自驾旅游路线图,你会知道城市间的高速公路长度、以及该公路要收取的过路费。现在需要你写一个程序,帮助前来咨询的游客找一条出发地和目的地之间的最短路径。如果有若干条路径都是最短的,那么需要输出最便宜的一条路径。

输入格式:

输入说明:输入数据的第1行给出4个正整数NMSD,其中N2N500)是城市的个数,顺便假设城市的编号为0~(N1);M是高速公路的条数;S是出发地的城市编号;D是目的地的城市编号。随后的M行中,每行给出一条高速公路的信息,分别是:城市1、城市2、高速公路长度、收费额,中间用空格分开,数字均为整数且不超过500。输入保证解的存在。

输出格式:

在一行里输出路径的长度和收费总额,数字间以空格分隔,输出结尾不能有多余空格。

输入样例:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

输出样例:

3 40
#include <iostream>
#include <stdio.h> 
#include <string.h>
#define INF 9999999
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace  std;
int map[600][600];
int cost[600][600];
int Mcost[600];
int path[600];
int dis[600];
int vis[600];
int n,m,s,d,a,b,c,p;
int main(int argc, char *argv[]) 
{
	cin>>n>>m>>s>>d;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			map[i][j]=INF;
			cost[i][j]=INF;
		}
	}
	for(int i=1;i<=m;i++)
	{
		cin>>a>>b>>c>>p;
		map[a][b]=c;
		map[b][a]=c;
		cost[a][b]=p;
		cost[b][a]=p;
	}
	map[s][s]=0;
	memset(vis,0,sizeof(vis));
	memset(path,-1,sizeof(path));
	for(int i=0;i<n;i++) dis[i]=INF;
	dis[s]=0;
	Mcost[s]=0;
	for(int i=0;i<n;i++)
	{
		int x,m=INF;
		for(int y=0;y<n;y++)
		{
			if(!vis[y]&&dis[y]<=m)
			{
				m=dis[y];
				x=y;
			}
		}
		vis[x]=1;
		for(int y=0;y<n;y++)
		{
			 if(dis[x]+map[x][y]<dis[y])
			 {
			 	dis[y]=dis[x]+map[x][y];
			 	Mcost[y]=Mcost[x]+cost[x][y];
			 }else if(dis[x]+map[x][y]==dis[y]&&Mcost[y]>Mcost[x]+cost[x][y])
			 {
			 	Mcost[y]=Mcost[x]+cost[x][y];
			 }
		}
	}
	cout<<dis[d]<<" "<<Mcost[d];
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值