最短路练习11/poj/3159 【差分约束系统】Candies


题目链接:http://poj.org/problem?id=3159
【差分约束系统】 Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 31132 Accepted: 8668

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

没看题解前完全不知道题是啥意思,完全不能把这道题跟最短路联系在一块0.0

题意:现在有一些小朋友,有许多的糖果,给出m组关系;例如1   2   5表示1号小朋友不想让2号小朋友比他多超过5个糖果,2   1   4表示2号小朋友不想让1号小朋友比他多超过4个糖果,

然后列为关系式:a2-a1<=5,a1-a2<=4;求1号小朋友和n号小朋友最多能相差多少糖果;

思路:差分约束系统是什么东东我看了一晚上也没怎么弄明白。就知道这道题是差分约束的裸模板;

看不懂就把它当成最短路就行,例如样例,把样例变成a2<=a1+5,a1<=a2+4;这是不是很像最短路呢?

dis[i]<=dis[j]+map[j][i];

这道题有一个极大的坑点;自己打的代码一直超时,我还一直觉得没毛病啊;看了AC代码好久才发现,用队列就超时

然后把超时的代码改成 数组模拟队列然后就过了。这道题数据量挺大的,必须用邻接表。

附上AC代码:(数组模拟队列,数组模拟邻接表)


  
  
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>
#include<string>
#include<vector> #include<map> #define LL long long
using namespace std;
#define eps 1e-8 #define N 30005 #define M 150005
const int maxx = 1e6 +10;
const int mod = 1e7+7; const int inf = 0x3f; int n,m,cnt=0,a,b,c,k;
void add(int s,int e,int v)
int head[N],dis[N],vis[N],q[N],next[M]; struct node{int y,num;}p[M]; { p[cnt].y=e; p[cnt].num=v;
dis[e]=dis[s]+v;
next[cnt]=head[s]; head[s]=cnt++; } bool relax(int s,int e,int v) { if(dis[s]+v<dis[e]) { return 1;
dis[1]=0;
} return 0; } void Bellman_ford() { int top,f; memset(vis,0,sizeof(vis)); memset(dis,inf,sizeof(dis));
while(k!=-1)
top=0; q[top++]=1; vis[1]=1; while(top) { f=q[--top]; vis[f]=0; k=head[f]; {
}
if(relax(f,p[k].y,p[k].num)&&!vis[p[k].y]) { vis[p[k].y]=1; q[top++]=p[k].y; k=next[k]; } } }
Bellman_ford();
int main() { scanf("%d%d",&n,&m); memset(head,-1,sizeof(head)); for(int i=1; i<=m; i++) { scanf("%d%d%d",&a,&b,&c); add(a,b,c); }
}
printf("%d\n",dis[n]);



















  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值