HDU Fire Net 1045 二分匹配

传送门Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12312    Accepted Submission(s): 7436


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
  
  
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
  
  
5 1 5 2 4
题意:两个在同一行的碉堡之间必须有墙隔开,问在地图上最多能放多少碉堡。

思路:二分匹配。

需要先将地图处理一下,任意的两个碉堡的x,y坐标都不能相同,

那么地图

4

。x  。。

。。。。

x  x  。。

。。。。

横着来变成了

1  x  2  2(同一行中被墙隔开的不算做是同一行了)(竖着同理)

3  3  3  3

x  x  4  4

5  5  5  5

竖着来变成了

1  x  5  6

1  3  5  6

x  x  5  6

2  4  5  6

除x点外找到了(1,1)(2,5)(2,6)(3,1)(3,3)(3,5)(3,6)(4,5)(4,6)(5,2)(5,4)(5,5)(5,6)

每个位置放置碉堡所占的横纵坐标,

每个横坐标的数字只能用一次,

横坐标    能选择的纵坐标

1            1

2            5,6

3            1,3,5,6

4            5,6

5            2,4,5,6

二分匹配,找最多的匹配对数;

#include<iostream>
#include <cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
int n,m;
int g[30][30];
int line[30];
char f[5][5];
int h[5][5];
int vis[30];
int find(int v)
{
    for(int i=1;i<=m;i++)
        if(g[v][i]&&!vis[i])
        {
            vis[i]=1;
            if(!line[i]||find(line[i]))
            {
                line[i]=v;
                return 1;
            }
        }
        return 0;
}
int main()
{
    int t;
    while(~scanf("%d",&t)&&t)
    {
        memset(g,0,sizeof(g));
        for(int i=0;i<t;i++)
          scanf("%s",f[i]);
          int num=1;
          for(int i=0;i<t;i++)//数字可能会偏大但是不影响结果,处理横坐标
          {
              for(int j=0;j<t;j++)
                  if(f[i][j]=='X')
                    num++;
                  else
                    h[i][j]=num;
                    num++;
          }
          n=num;
          num=1;
          for(int j=0;j<t;j++)
          {
              for(int i=0;i<t;i++)
                  if(f[i][j]=='X')
                    num++;
                  else
                    g[h[i][j]][num]=1;
               num++;
          }
           m=num;
           memset(line,0,sizeof(line));
           int ans=0;
           for(int i=1;i<=n;i++)
           {
               memset(vis,0,sizeof(vis));
               if(find(i))
                ans++;
           }
           printf("%d\n",ans);
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值