hdu5178——pairs【尺取法,二分】

pairs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4256    Accepted Submission(s): 1518


 

Problem Description

John has n points on the X axis, and their coordinates are (x[i],0),(i=0,1,2,…,n−1) . He wants to know how many pairs<a,b> that |x[b]−x[a]|≤k.(a<b)

 

 

Input

The first line contains a single integer T (about 5), indicating the number of cases.
Each test case begins with two integers n,k(1≤n≤100000,1≤k≤109) .
Next n lines contain an integer x[i](−109≤x[i]≤109) , means the X coordinates.

 

 

 

Output

For each case, output an integer means how many pairs<a,b> that |x[b]−x[a]|≤k .

 

 

Sample Input

 

2 5 5 -100 0 100 101 102 5 300 -100 0 100 101 102

 

 

Sample Output

 

3 10

 

 

Source

BestCoder Round #31

 

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  6318 6317 6316 6315 6314 

 

 

Statistic | Submit | Discuss | Note

 

用尺取法,以每一个数的开始坐标为上界开始搜索。

#include<algorithm>
#include<cstdio>
#include<iostream>
using namespace std;
const int MAXN=1000005;
typedef long long LL;
LL a[MAXN];
bool cmp(LL a,LL b){
    return a<b;
}
int main(){
    LL n,t,k;
    scanf("%lld",&t);
    while(t--){
        scanf("%lld%lld",&n,&k);
        for(int i=0;i<n;i++){
            scanf("%lld",&a[i]);
        }
        sort(a,a+n,cmp);
        LL ans=0,i,j;
        for(i=0,j=0;i<n;i++){
            //printf("%lld\n",j);
            while(j+1<n&&a[j+1]-a[i]<=k) j++;
            ans=ans+(j-i);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值