HDU 1242 Rescue(BFS优先队列)

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28234    Accepted Submission(s): 10002



Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
13

题解:大意为天使被魔头抓走了,关在了监狱内,监狱为二维字符数组,其中,r为营救者,a为天使,x为警卫,#为墙,营救者每走一格花费一分钟,且它足够强大可以杀死所有的守卫,但必须多花费一分钟……
用优先队列来做……


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<math.h>
#include<queue>;
#include<stack>;
#include <iostream>
#include <queue>
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
char map[201][201];                          /*储存监狱……*/
bool v[201][201];                            /*标记……*/
int d[4][2]={{1,0},{-1,0},{0,1},{0,-1}};     /*营救者的四种走法……*/
int n,m,a,b,aa,bb;
struct node                                  /*定义优先队列*/
{
    int x,y,s,time;
    bool operator<(const node &z)const
    {
        return time>z.time;
    }
};
int check(int x,int y)                           /*判断此时的坐标是否可走*/
{
    if(x>=0&&x<n&&y>=0&&y<m&&map[x][y]!='#'&&!v[x][y])
        return 1;
    return 0;
}
void bfs()
{
    priority_queue<node>q;                     /*优先队列……*/
    node start,next;
    start.x=a,start.y=b,start.time=0;
    q.push(start);
    while(!q.empty())
    {
        start=q.top();
        q.pop();
        if(start.x==aa&&start.y==bb){printf("%d\n",start.time);return;}     /*找到,结束*/
        for(int i=0;i<4;i++)
        {
            next.x=start.x+d[i][0],next.y=start.y+d[i][1];
            if(check(next.x,next.y))
            {
                if(map[next.x][next.y]=='x')
                    next.time=start.time+2;
                else
                    next.time=start.time+1;
                v[next.x][next.y]=true;
                q.push(next);
            }
        }
    }
    printf("Poor ANGEL has to stay in the prison all his life.\n");return;   /*未找到……*/
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        getchar();
        mem(v);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j]=='r')
                    a=i,b=j;
                if(map[i][j]=='a')
                    aa=i,bb=j;
            }
            getchar();
        }
        v[a][b]=true;
        bfs();
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值