Final Ugly English

Final Ugly English

Time Limit: 1000 MS        Memory Limit: 32768 K

Description

ACM twist-toy encountered such a problem in the work, this article, to ensure that this article only lowercase letters 

and spaces, please send the articles in each word inverted output, such as "hello world this is an competition". You 

should output "olleh dlrow siht si na noititepmoc".

Input

A group of data, each line of data input from the lower case letters and spaces of the article, the length of not more than

 one thousand

Output

Output a line for each word after the reversal of the article.

Sample Input

hello world this is an competition

Sample Output

olleh dlrow siht si na noititepmoc


题解:题意大概为给你一段文章,把每个单词倒着输出……


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<string>
#include<math.h>
#include<map>
#include<queue>
#include<stack>
#define INF 0x3f3f3f3f
#define ll long long
#define For(i,a,b)  for(int i=a;i<b;i++)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int n,m;
char x[100005];
char y[1000];
int main()
{
    while(gets(x))
    {

        int a=strlen(x);
        x[a]=' ';
        int p=0;
        For(i,0,a+1)
        {
            if(x[i]<='z'&&x[i]>='a')
            {

                y[p]=x[i];
                p++;
            }
            else if(x[i]==' ')
            {
                for(int j=p-1; j>=0; j--)
                {
                    printf("%c",y[j]);
                }
                p=0;
                if(i!=a)
                    printf(" ");
            }
        }
        printf("\n");
    }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值