Secrete Master Plan (模拟)

Secrete Master Plan

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1159    Accepted Submission(s): 686



Problem Description
Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form 2×2 matrix, but Fei didn't know the correct direction to hold the sheet. What a pity!

Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.

 

Input
The first line of the input gives the number of test cases, T(1T104) . T test cases follow. Each test case contains 4 lines. Each line contains two integers ai0 and ai1 ( 1ai0,ai1100 ). The first two lines stands for the original plan, the 3rd and 4th line stands for the plan Fei opened.
 

Output
For each test case, output one line containing "Case #x: y", where x is the test case number
(starting from 1) and y is either "POSSIBLE" or "IMPOSSIBLE" (quotes for clarity).
 

Sample Input
  
  
4 1 2 3 4 1 2 3 4 1 2 3 4 3 1 4 2 1 2 3 4 3 2 4 1 1 2 3 4 4 3 2 1
 

Sample Output
Case #1: POSSIBLE
Case #2: POSSIBLE
Case #3: IMPOSSIBLE
Case #4: POSSIBLE



题解:题目大意为给你两组数据,每组数据四个字(围成圈),让你判断两组数据是否有可能相同……

      
思路:以为围成一个圈,开一个二倍的数组,逐一比较就好了……


#include<bits/stdc++.h>
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<string>
#include<math.h>
#include<map>
#include<queue>
#include<stack>
#define INF 0x3f3f3f3f
#define ll long long
#define For(i,a,b) for(int i=a;i<b;i++)
#define sf(a)  scanf("%d",&a)
#define sfs(a)  scanf("%s",a)
#define sff(a,b)  scanf("%d%d",&a,&b)
#define sfff(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define pf(a) printf("%d\n",a)
#define P()  printf("\n")
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int x[10];
int main()
{
    int t,a,b,c,d,s=0;
    sf(t);
    while(t--)
    {
        s++;
        sfff(a,b,d);
        sf(c);
        sfff(x[0],x[1],x[3]);sf(x[2]);
        printf("Case #%d: ",s);
        for(int i=4;i<8;i++)
        {
            x[i]=x[i%4];
        }
        int flag=0;
        for(int i=0;i<8;i++)
        {
            if(x[i]==a&&x[i+1]==b&&x[i+2]==c&&x[i+3]==d)
            {
                flag=1;
            }
        }
        if(flag)printf("POSSIBLE\n");
        else printf("IMPOSSIBLE\n");
    }
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值