HDU - 1233 - 还是畅通工程


题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1233

题目描述

Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5

解题思路

最小生成树的例题
最小生成树详解

AC代码

#include<iostream>
#include<cstring> 
#include<algorithm>
#define maxn 110
#define inf 0x3f3f3f3f
using namespace std;

int n, t;
int pre[maxn];

struct node {
    int x, y, cost;
}cnt[5050];

bool cmp(node a, node b) {
    return a.cost < b.cost;
}

int find(int x) {
    return x == pre[x] ? x : find(pre[x]);
}

int kruskal() {
    int ans = 0;
    for(int i = 1; i <= n; i++) pre[i] = i;
    sort(cnt+1, cnt+1+t, cmp);
    for(int i = 1; i <= t; i++) {
        int x = find(cnt[i].x);
        int y = find(cnt[i].y);
        if(x != y) {
            ans += cnt[i].cost;
            pre[y] = x;
        }
    }
    return ans;
}

int main() {
    while(scanf("%d", &n) && n) {
        t = n*(n-1)/2;
        for(int i = 1; i <= t; i++) {
            scanf("%d %d %d", &cnt[i].x, &cnt[i].y, &cnt[i].cost);
        }
        printf("%d\n", kruskal());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值