Problem Description
输入一个十进制数N,将它转换成R进制数输出。
Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
Sample Input
7 2
23 12
-4 3
Sample Output
111
1B
-11
自己的代码
#include<stdio.h>
main()
{
int m,n,q,a[10];
while(scanf("%d%d",&m,&n)!=EOF)
{
p=q=0;
if(m<0)
{
m=-1*m;
p=1;
}
do
{
a[q++]=m%n;
m=m/n;
}while(m);
if(p==1)
printf("-");
while(q--)
{
if(a[q]>9)
printf("%c",'A'+a[q]-10);
else
printf("%d",a[q]);
}
printf("\n");
}
return 0;
}
找的大神代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
int a,b;
char c[100];
while(~scanf("%d%d",&a,&b))
{
if(a<0)
{
printf("-"); a=-a;
} itoa(a,c,b); strupr(c); puts(c);
}
}