1061:Rightmost Digit(代码超级简洁)

21 篇文章 1 订阅
14 篇文章 1 订阅

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
7
6

先展示未通过验证的代码:

//ACM 1061:Rightmost Digit
#include <iostream>
using namespace std;

int main()
{
	int T,N,r_n=1;
	cin >> T;
	while(T--)
	{
		cin >> N;
		if(N < 1 || N > 1000000000)
			break;
		if(N % 10 == 4 || N % 10 == 8)
			r_n = 6;
		else 
			if(N % 10 == 0)
				r_n = 0;
			else
			{
				int k = N % 4;
				for (int i = 0;i < k;i++)
				{
					r_n *= N;
					r_n %= 10;
				}
			}
			cout << r_n << endl;
			r_n=1;		
	}
	return 0;
}

分析如图:


下面是经过修改验证通过的代码:


#include<iostream>
using namespace std;

int main()
{
	int T,N,k,temp;
	cin >> T;
	while(T--)
	{
		temp = 1;
		cin >> N;
		k = (N - 1) % 4;
		N = N % 10;
		for(int i = 0;i <= k;i++)
			temp *= N;
		//****************错误代码*********************//
		/*
		T = N % 4;
		N = N % 10;
		for(int i = 0;i < T;i++)//此处忽略了T等于零的情景
		temp *= N;
		*///******************************************//
		cout << temp % 10 << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值