elasticsearch6升级7后hive映射表报错es hadoop illegal argument canot detect es version 问题解决

报错日志

使用dbview 查询hive里面的es映射表,报错如下:
 

从错误来看,主要是两个原因:

1.es集群不可访问

2.es.nodes.wan.only属性设置不正确

排查思路

首先排查es集群访问的问题,经过排查发现es集群可用,由于没有其他变动,当时版本升级之前表可用,之后不可用,所以从版本这块考虑问题解决

首先去hive server2 web ui 的conf里面查看发现 hive服务加载的es-hadoop jar版本是6.的版本

CDH的hive配置如下:

下载好es-hadoop7的版本,并且修改CDH配置

修改重启hive之后 问题还是这样 ,然后发现 cm的监控界面

hive server2 web ui 的conf里面

还是没变

解决

最后直接去hive server2所在的节点上的

路径把6.的jar删掉 直接换成7.的jar ,重启hive server2服务 问题解决

  • 0
    点赞
  • 0
    收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:技术工厂 设计师:CSDN官方博客 返回首页
评论

打赏作者

果木

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值