hdu 1520

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9235    Accepted Submission(s): 3965


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
  
  
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
  
  
5
 
思路:
简单的树形DP。
每个结点有两种状态,参加和不参加,用0表示不参加,1表示参加
dp[i][1]表示第i个参与者参加了,dp[i][0]表示第i个参与者没有参加。
状态转移方程:dp[u][0] += max (dp[v][0], dp[v][1]) ,dp[u][1] += dp[v][0] ;
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=6005;
ll dp[maxn][2];
bool vis[maxn];
struct node
{
	int en,next;
}Edge[maxn*4];
int num,head[maxn],val[maxn];
ll ans[maxn];
void add(int st,int en)
{
	Edge[num].en=en;
	Edge[num].next=head[st];
	head[st]=num++;
}
void dfs(int u)
{
	vis[u]=true;
	for(int i=head[u];i!=-1;i=Edge[i].next)
	{
		int v=Edge[i].en;
		if(vis[v]) continue;
		dfs(v);
		dp[u][0]+=max(dp[v][0],dp[v][1]);
		dp[u][1]+=dp[v][0];
		ans[u]=max(dp[u][1],dp[u][0]);
	}
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		num=0;
		memset(head,-1,sizeof(head));
		memset(vis,0,sizeof(vis));
		memset(Edge,0,sizeof(Edge));
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&val[i]);
			dp[i][0]=0;
			dp[i][1]=val[i];
		}
		int st,en;
		while(scanf("%d%d",&st,&en)!=EOF)
		{
			if(st==0&&en==0) break;
			add(st,en);
			add(en,st);
		}
		dfs(1);
		ll ans1=-1;
		for(int i=1;i<=n;i++)
		ans1=max(ans1,ans[i]);
		printf("%lld\n",ans1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值