poj 1155

Description
A TV-network plans to broadcast an important football match. Their network of transmitters and users can be represented as a tree. The root of the tree is a transmitter that emits the football match, the leaves of the tree are the potential users and other vertices in the tree are relays (transmitters). 
The price of transmission of a signal from one transmitter to another or to the user is given. A price of the entire broadcast is the sum of prices of all individual signal transmissions. 
Every user is ready to pay a certain amount of money to watch the match and the TV-network then decides whether or not to provide the user with the signal. 
Write a program that will find the maximal number of users able to watch the match so that the TV-network's doesn't lose money from broadcasting the match.
Input
The first line of the input file contains two integers N and M, 2 <= N <= 3000, 1 <= M <= N-1, the number of vertices in the tree and the number of potential users. 
The root of the tree is marked with the number 1, while other transmitters are numbered 2 to N-M and potential users are numbered N-M+1 to N. 
The following N-M lines contain data about the transmitters in the following form: 
K A1 C1 A2 C2 ... AK CK 
Means that a transmitter transmits the signal to K transmitters or users, every one of them described by the pair of numbers A and C, the transmitter or user's number and the cost of transmitting the signal to them. 
The last line contains the data about users, containing M integers representing respectively the price every one of them is willing to pay to watch the match.
Output
The first and the only line of the output file should contain the maximal number of users described in the above text.
Sample Input
9 6
3 2 2 3 2 9 3
2 4 2 5 2
3 6 2 7 2 8 2
4 3 3 3 1 1
Sample Output
5


题意:有一个电视台广播节目,广播的网络用一棵树表示,节点1表示电台,叶子结点表示用户,用户愿意付一定的钱去收看这个节目,从非叶子结点到其他结点需要一定的费用(即从中继点到另一个中继点需要一些钱),问最后在不亏本的情况下,最多能使多少人收看到节目。


定义dp[i][j]表示在节点i为根节点的子树下,有j个人收看节点的最大利润。

状态转移方程是:dp[i][j]=max(dp[i][j],dp[i][j-k]+dp[son of i][k])

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 3005;
const int inf = 0x7f7f7f7f;
struct node
{
	int en, next, len;
}Edge[maxn*2];
int n, m, tot;
int num[maxn], head[maxn], dp[maxn][maxn], tmp[maxn];
void add(int st, int en,int len)
{
	Edge[tot].en = en;
	Edge[tot].len = len;
	Edge[tot].next = head[st];
	head[st] = tot++;
}
void init()
{
	tot = 0;
	memset(head, -1, sizeof(head));
	memset(Edge, 0, sizeof(Edge));
	memset(num, 0, sizeof(num));
}
void dfs(int u)
{
	int i, j, k, v;
	for (int i = head[u];i != -1;i = Edge[i].next)
	{
		v = Edge[i].en;
		dfs(v);
		for (j = 0;j <= num[u];j++)
			tmp[j] = dp[u][j];
		for (j = 0;j <= num[u];j++)
		{
			for (k = 1;k <= num[v];k++)
				dp[u][k + j] = max(dp[u][k + j], tmp[j] + dp[v][k] - Edge[i].len);
		}
		num[u] += num[v];
	}
}
int main()
{
	while (scanf("%d%d", &n, &m) != EOF)
	{
		init();
		for (int i = 1;i <= n - m;i++)
		{
			int k;
			scanf("%d", &k);
			for (int j = 0;j < k;j++)
			{
				int a, b;
				scanf("%d%d", &a, &b);
				add(i, a, b);
			}
		}
		for (int i = 1;i <= n;i++)
			for (int j = 1;j <= m;j++)
				dp[i][j] = -inf;
		for (int i = n - m + 1;i <= n;i++)
		{
			num[i] = 1;
			scanf("%d", &dp[i][1]);
		}
		dfs(1);
		for (int i = m;i >= 0;i--)
		{
			if (dp[1][i] >= 0)
			{
				printf("%d\n", i);
				break;
			}
		}
	}  
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值