The ? 1 ? 2 ? ... ? n = k problem
Time Limit: 3000MS Memory limit: 65536K
题目描述
Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k
For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7
输入
The first line is the number of test cases, followed by a blank line.
Each test case of the input contains integer k (0<=|k|<=1000000000).
Each test case will be separated by a single line.
输出
For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.
Print a blank line between the outputs for two consecutive test cases.
示例输入
2 12 -3646397
示例输出
7 2701
提示
题目:前几个数从1到n 前面可以使加号也可以是减号~ 求相加之和等于目标值得时候n的最小值
思路:条件一:从1到n相加之和必须大于目标值k
条件二:若有一个值x满足1+2+3+4+5+…x+n=k2
且k2-k=2x 即相减之后 为偶数
#include<iostream>
using namespace std;
int main()
{
int k;
int cas;
int temp;
int n;
int temp2;
int i;
cin>>cas;
while(cas--)
{
cin>>k;
k=abs(k);
for(i=0;;i++)
{
temp=i*(i+1)/2;
if(temp>k) break;
}
n=i;
for(i=0;;i++)
{
temp2=n*(n+1)/2-k;
if(temp2%2==0) break;
n++;
}
cout<<n<<endl;
if(cas) cout<<endl;
}
return 0;
}