poj 2828 线段树+单点更新

题目:

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 19511 Accepted: 9659

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.




n个人胡乱插队,对于每个人给出a和b,a表示这个人插在第a个人的后面(0表示售票台),b表示这个人的属性值。所有人插队完毕之后从前向后依次输出每个人的属性值。


分析:
不太容易想到用线段树。如果正序直接模拟,由于n数量过大,目测会超时。这时想到插队操作和单点更新有些联系。但是如果从前向后正序更新,则前面更新过的点后面有可能再次更新,代价大。最后插队的人的位置肯定不会再次变动,因此可以从后向前更新,每个人只要找到当前第a+1个空的位置站在这儿就可以了。线段树结点用来维护当前区间的空位置数。


代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<ctype.h>    //tower()
#include<set>  
#include<map>  
#include<iomanip>// cout<<setprecision(1)<<fixed<<a;
#include<vector>   
#include<time.h>  
#include<assert.h>  //assert
#include<cmath>	
#include<algorithm>
#include<bitset>
#include<limits.h>
#include<stack>
#include<queue>
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn=200010;

int stree[maxn<<2],n;
int a[maxn],b[maxn],ans[maxn];

void built(int rt,int l,int r){
	if(l==r){
		stree[rt]=1;//一开始每个位置都有空 
		return;
	}
	int mid=(l+r)>>1;
	built(rt<<1,l,mid);
	built(rt<<1|1,mid+1,r);
	stree[rt]=stree[rt<<1]+stree[rt<<1|1];
}


void update(int rt,int l,int r,int va,int x){
	stree[rt]--;
	if(l==r){
		ans[l]=va;
		return;
	}
	int mid=(l+r)>>1;
	if(stree[rt<<1]>=x){
		update(rt<<1,l,mid,va,x);
		return ;
	}
	x-=stree[rt<<1];
	update(rt<<1|1,mid+1,r,va,x);
}

int main(){//4568K	1329MS	
	while(~scanf("%d",&n)){
		built(1,1,n);
		for(int i=1;i<=n;++i){
			scanf("%d%d",a+i,b+i);
		}
		for(int i=n;i>=1;--i){
			update(1,1,n,b[i],a[i]+1);
		}
		printf("%d",ans[1]);
		for(int i=2;i<=n;++i) printf(" %d",ans[i]);
        printf("\n");
	}
	return 0;
}

还可以用树状数组做,需要用到部分和操作...待补坑

https://github.com/eecrazy/ACM/blob/master/%E6%95%B0%E6%8D%AE%E7%BB%93%E6%9E%84/%E6%A0%91%E7%8A%B6%E6%95%B0%E7%BB%84/poj%202828%E6%A0%91%E7%8A%B6%E6%95%B0%E7%BB%84%E9%AB%98%E7%BA%A7%E6%93%8D%E4%BD%9C-%E4%BA%8C%E5%88%86Buy%20Tickets.cpp



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值