poj 2823 单调队列

题目:

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 60430 Accepted: 17320
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source


给n个数,求连续区间长度为k的最大和最小值。

固定区间最值问题 可以用单调队列


单调队列中保存的是下标,下标是严格递增的 但下标对应的原数组中的内容可以是递增的也可以是递减的 对应单调递增/递减队列

通过改变队尾维护单调性 通过改变队首维护固定区间(区间长度不变)


代码:

假装原创 其实代码几乎照搬自:

http://blog.csdn.net/cc_again/article/details/11841797

#include<stdio.h>
#include<iostream>
using namespace std;
const int maxn=1e6+10;

int a[maxn];
int q1[maxn],q2[maxn];
int ans1[maxn],ans2[maxn];

int main()
{//G++ TLE C++ 10944K	5235MS
   int n,k;
   while(scanf("%d%d",&n,&k)==2) {
       for(int i=1;i<=n;i++) scanf("%d",&a[i]);
       int h1=0,t1=-1;
       int h2=0,t2=-1,cnt=0;
       for(int i=1;i<=n;i++) {
            while(h1<=t1&&a[i]<=a[q1[t1]])//递增队列
                t1--;
            while(h2<=t2&&a[i]>=a[q2[t2]])//队尾的更小
                t2--;
            q2[++t2]=i;
            q1[++t1]=i;
            while(q1[h1]<i-k+1)
                h1++;
            while(q2[h2]<i-k+1)
                h2++;
            if(i>=k) {
                ans1[++cnt]=a[q1[h1]];//队首维护区间最小值
                ans2[cnt]=a[q2[h2]];//最大值
            }
       }
       printf("%d",ans1[1]);
       for(int i=2;i<=cnt;i++)
            printf(" %d",ans1[i]);
       printf("\n%d",ans2[1]);
       for(int i=2;i<=cnt;i++)
            printf(" %d",ans2[i]);
       putchar('\n');
   }
   return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值