poj 1014 多重背包

题目:

Dividing
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 71372 Accepted: 18606

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

给定一堆 大理石 每一个大理石都有一个价值,是1-6之间的一个数 问能否将它们分成两堆,使得两堆价值之和相等


分析:

拉出多重背包定义:

有N种物品和一个容量为V的背包。第i种物品最多有n[i]件可用,每件费用是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的费用总和不超过背包容量,且价值总和最大。

可见大理石的费用和价值是同一个值 分析样例可以推断出,如果容量为sum/2的背包能够完全装满,则可分 否则不可分 

如第一个样例 sum=12 而容量为6的背包是无法用已有大理石装满的

背包容量上限为20000*6/2=60000


代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int inf=-0x3f3f3f3f;
const int maxn=60020;

int val[10],cost[10],num[10],dp[maxn];
int n,v;

inline void compak(int val,int cost){
    for(int i=cost;i<=v;++i){
        dp[i]=max(dp[i],dp[i-cost]+val);
    }
}

inline void zeroone(int val,int cost){
    for(int i=v;i>=cost;--i){
        dp[i]=max(dp[i],dp[i-cost]+val);
    }
}

inline void mulpak(int val,int cost,int num){
    if(cost*num>=v){///这种物品费用总和大于V 相当于在V的范围内可以任取多件 转化为完全背包问题
        compak(val,cost);
        return;
    }
    int k=1;
    while(k<num){
        zeroone(k*val,k*cost);
        num-=k;
        k<<=1;
    }
    zeroone(num*val,num*cost);
}

int main(){///916K	16MS
    int cas=0;
    for(int i=1;i<=8;++i) cost[i]=i,val[i]=i;
    while(scanf("%d%d%d%d%d%d",&num[1],&num[2],&num[3],&num[4],&num[5],&num[6])==6){
        cas++;
        if(!num[1] && !num[2] &&!num[3] &&!num[4] &&!num[5] &&!num[6]) break;
        if(cas!=1) puts("");
        v=0;
        for(int i=1;i<=6;++i) v+=num[i]*i;
        if(v%2){
            printf("Collection #%d:\nCan't be divided.\n",cas);
            continue;
        }
        v/=2;
        for(int i=1;i<=v;++i) dp[i]=inf;///恰为 初始化为负数
        dp[0]=0;///容量恰为0时价值总和为零
        for(int i=1;i<=6;++i) mulpak(cost[i],cost[i],num[i]);
        if(dp[v]==v) printf("Collection #%d:\nCan be divided.\n",cas);
        else printf("Collection #%d:\nCan't be divided.\n",cas);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值