数学题

We have two rows. There are a dots on the top row and b dots on the bottom row. We draw line segments connecting every dot on the top row with every dot on the bottom row. The dots are arranged in such a way that the number of internal intersections among the line segments is maximized. To achieve this goal we must not allow more than two line segments to intersect in a point. The intersection points on the top row and the bottom are not included in our count; we can allow more than two line segments to intersect on those two rows. Given the value of a and b, your task is to compute P(a,b), the number of intersections in between the two rows. For example, in the following figure a = 2 and b = 3. This figure illustrates that P(2,3) = 3.
Input Each line in the input will contain two positive integers a (0 < a ≤ 20000) and b (0 < b ≤ 20000). Input is terminated by a line where both a and b are zero. This case should not be processed. You will need to process at most 1200 sets of inputs.
Output
For each line of input, print in a line the serial of output followed by the value of P(a,b). Look at the output for sample input for details. You can assume that the output for the test cases will fit in 64-bit signed integers.
Sample Input
2 2 2 3 3 3 0 0
Sample Output
Case 1: 1 Case 2: 3 Case 3: 9
这个题很简单,找到了和*和的规律

#include<iostream>
using namespace std;
typedef long long ll;
int main()
{
    ll a,b;
    ll k=0;
    ll sum1,sum2;
    while(cin>>a>>b&&(a||b))
    {
        sum1=sum2=0;
        if(a>b)
        {
            ll t=a;
            a=b;
            b=t;
        }
        cout<<"Case "<<++k;
        if(a==0)
            cout<<": 0"<<endl;
        else
        {
            for(ll i=1;i<a;i++)
                sum1+=i;
            for(ll i=1;i<b;i++)
                sum2+=i;
            cout<<": "<<sum1*sum2<<endl;
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值