简单NIm


题目地址:http://115.231.222.240:8081/JudgeOnline/

Problem F: qwb has a lot of Coins

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 661   Solved: 199
[ Submit][ Status][ Web Board]

Description

qwb has a lot of coins. One day, he decides to play a game with his friend using these coins. He first puts some of his coins into M piles, each of which is composed of Ni (1<=i<=M) coins. Then, the two players play the coin game in turns. Every step, one can remove one or more coins from only one pile. The winner is the one who removes the last coin.
Then comes the question: How many different ways the first player can do that will ensure him win the game? 

Input

Input contains multiple test cases till the end of file. Each test case starts with a number M (1 <= M<= 1000) meaning the number of piles. The next line contains M integers Ni (1 <= Ni <= 1e9, 1 <= i<= M) indicating the number of coins in pile i.

Output

For each case, put the method count in one line.
If the first player can win the game, the method count is the number of different ways that he can do to ensure him win the game, otherwise zero.

Sample Input

3
1 2 3
1
1

Sample Output

0

题意:给出几堆数,然后要求先取者为胜的情况。

思路:nim表示的是所有的数异或为1那么先取者胜,否则先取者败。

然后就是选取某一堆的时候,其他的数异或起来比这个数小的话,那么就能把这个数取成与其他数异或起来一样的值,使得所有的数的亦或值变成0,使得对手变成必败态。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 1000 + 10;
#define INF 0x7fffffff
#define clr(x,y) memset(x,y,sizeof(x))
typedef long long ll;
#define eps 10e-10
const ll Mod = 1000000007;
bool is_[maxn];
int prime[maxn];
ll pow_mod(ll x,ll n,ll mod_val)
{
    ll ans = 1;
    ll t = x % mod_val;
    while(n)
    {
        if(n & 1)
        {
            ans = ans * t % mod_val;
        }
        n >>= 1;
        t = t * t % mod_val;
    }
    return ans;
}
int a[maxn];
int sum1[maxn],sum2[maxn];
int main()
{
    int n;
    while( ~ scanf("%d",&n))
    {
        for(int i = 1; i <= n; i ++)
            scanf("%d",&a[i]);
        sum1[0] = sum2[n + 1] = 0;
        for(int i = 1; i <= n; i ++)
            sum1[i] = sum1[i - 1] ^ a[i];
        for(int i = n; i >= 1; i --)
            sum2[i] = sum2[i + 1] ^ a[i];
        int ans = 0;
        for(int i = 1; i <= n; i ++)
        {
            int t = sum1[i - 1] ^ sum2[i + 1];
            if(a[i] > t)
                ans ++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
 
/**************************************************************
    Problem: 1485
    User: ZJC2017Final110
    Language: C++
    Result: Accepted
    Time:52 ms
    Memory:1728 kb
****************************************************************/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值