HDU1002 A + B Problem II【大数】

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 438282    Accepted Submission(s): 85280


 

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

 

Sample Input

 

2 1 2 112233445566778899 998877665544332211

 

 

Sample Output

 

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 

 

Author

Ignatius.L

 

 

Recommend

 

 

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const int BASE = 10;
const int N = 1000;
char sa[N+1],sb[N+1];
int a[N+1],b[N+1];

int main()
{
    int t;
    scanf("%d",&t);

    for(int k=1;k<=t;k++){
        scanf("%s%s",sa,sb);

        //字符串转数值数组
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));

        int alen = strlen(sa);
        for(int i=alen-1,j=0;i>=0;i--,j++){
            a[j] = sa[i] - '0';//关键代码,把字符串转换为数值
        }
        int blen = strlen(sb);
        for(int i=blen-1,j=0;i>=0;i--,j++){
            b[j] = sb[i] - '0';//同理
        }

        //相加(需要考虑进位问题)
        //倒着加的,从最低位开始相加,把最低位放在数组的第一个
        
        int len = max(alen,blen);
        int carry = 0;   //位
        for(int i=0;i<len;i++){
            a[i] += b[i] + carry;//加上位
            carry = a[i]/BASE;
            a[i] %= BASE;
        }

        if(carry >0){
            a[len++] = carry;
        }//最高位

        if(k != 1)
            printf("\n");
        printf("Case %d:\n", k);
        printf ("%s + %s = ", sa, sb);

        for(int i=len-1;i>=0;i--){
            printf("%d",a[i]);
        }//倒着输出,就是相当于从最高位开始输出

        printf("\n");

    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值