Red and Black POJ - 1979

10 篇文章 0 订阅

 

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

搜索的类型题目

中文题目:

有一个长方形的房间,上面铺着方形的瓷砖。每个瓷砖都是红色的或黑色的。一个男人站在一块黑色瓷砖上。从瓷砖,他可以移动到四个相邻的瓷砖之一。但他不能在红色瓷砖上移动,只能在黑色瓷砖上移动。

编写一个程序来计算黑瓷砖的数量,他可以通过重复上面描述的动作来达到。

输入:

输入由多个数据集组成。数据集以包含两个正整数W和H的直线开始;W和H分别是x方向和y方向上的瓷砖数。W和H不超过20。

数据集中有H多行,每一行包括W个字符。每个字符表示瓷砖的颜色,如下所示。

‘.’-一个黑色的瓷砖
‘#’-红色瓷砖
“@”-黑砖上的一个人(在一组数据中正好出现一次)
输入的末尾由两个零组成的一行表示。

输出:

对于每个数据集,您的程序应该输出一行,其中包含他可以从初始瓷砖(包括它本身)到达的瓷砖数量。

AC代码:

#include <iostream>

using namespace std;

int N,M,sum;
char MAP[105][105];
//int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
int dir[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};

void dfs(int x,int y){
	MAP[x][y] = '#';
	int xx,yy;//下一步
	for(int i=0; i<4; i++){
		xx = x + dir[i][0];
		yy = y + dir[i][1];
		if(MAP[xx][yy]=='.' && xx>=0 && xx<N && yy>=0 && yy<M){
			MAP[xx][yy] = '#';
			sum++;
			dfs(xx,yy);
		}
	} 
}

int main(void)
{
   while(cin>>M>>N && N && M){
   		sum = 1;
		for(int i=0; i<N; i++){
			for(int j=0; j<M; j++){
				cin >> MAP[i][j];
			}
		}
		
		for(int i=0; i<N; i++){
			for(int j=0; j<M; j++){
				if(MAP[i][j] == '@'){
					dfs(i,j);
					break;
				}
			}
		}
		
		cout << sum << endl;
		
   }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值