ithin R units of some palantir.
Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xnof each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.
Output
For each test case, print a single integer indicating the minimum number of palantirs needed.
Sample Input
0 3 10 20 20 10 7 70 30 1 7 15 20 50 -1 -1
Sample Output
2 4
Hint
In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.
In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.
思路:
每次首先找到没有被覆盖的最左边的点,然后在以此点为起点向右半径为R的右邻域内找到邻域内最右边的点,将这个点标记。然后再从这个标记的点的后面一个点开始重复上述操作。注意:首先对输入的位置信息排序。
AC代码:
#include <iostream>
#include <algorithm>
using namespace std;
const int MAX = 1000;
int N,R;
int X[MAX+10];
int main(void)
{
while((cin >> R >> N) && (N!=-1) && (R!=-1)){
for(int i=0; i<N; i++){
cin >> X[i];
}
sort(X,X+N);//对输入的数据进行排序
int i=0;//计数器
int ans=0;//最终确定的点数
while(i<N){
//首先找到直线最左边的点
int s = X[i++];//s是没有被覆盖的最左的点的位置
//根据这个点向右找到右边邻域最右侧的点
while(i<N && X[i] <= (s+R) ){
i++;//一直向右前进直到据s的距离大于R的点
}
int p = X[i-1];//p是新加上标记点的位置
while(i<N && X[i] <= (p+R) ){
i++;//一直向右前进直到据p的距离大于R的点
}
ans++;
}
cout << ans << endl;
}
return 0;
}