(HDU2102) A计划-BFS

A计划

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 30320    Accepted Submission(s): 7589


 

Problem Description

可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。

 

 

Input

输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。

 

 

Output

如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。

 

 

Sample Input

 

1 5 5 14 S*#*. .#... ..... ****. ...#. ..*.P #.*.. ***.. ...*. *.#..

 

 

Sample Output

 

YES

 题目大意:骑士从S出发,问能否在规定时间内到达公主所在地P。地图中的节点有三种类型。·表示平地,直接走就行;*代表墙不能走;#代表传送门,传送到另一层的相应位置,若另一层的相应位置为*,就死了。

分析:题目不难,但在bfs的条件判断上可能会有问题。我总结了一下。这种情况多的情况下,就将可能的情况及其相应的操作列举出来,然后将可以合并的条件合并一下,就ok了。

代码:

#include<iostream>
#include<queue>
using namespace std;

struct Node {
	int c,x, y;
	int step;
	Node(int cc = 0, int xx = 0, int yy = 0, int s = 0) {
		c = cc, x = xx, y = yy, step = s;
	}
};
char maze[2][12][12];
int N, M, T;
queue<Node> q;
int vis[2][12][12];
int px[4] = { -1,0,1,0 };
int py[4] = {0,1,0,-1};
void BFS(){
	Node temp;
	while (!q.empty())q.pop();
	q.push(Node(0,0,0,0));
	while (!q.empty())
	{
		temp = q.front();
		q.pop();
		int tc = temp.c;
		int tx = temp.x;
		int ty = temp.y;
		int ts = temp.step;
		for (int i = 0; i < 4; i++) {
			tx = temp.x + px[i];
			ty = temp.y + py[i];
			ts = temp.step + 1;
			tc = temp.c;
			if (tx < 0 || tx >= N || ty < 0 || ty >= M)continue;
			if (vis[tc][tx][ty])continue;
			if (maze[tc][tx][ty] == '.') {
				q.push(Node(tc, tx, ty, ts));
				vis[tc][tx][ty] = 1;
			}
			if (maze[tc][tx][ty] == '#'&&maze[!tc][tx][ty] != '#'&&maze[!tc][tx][ty] != '*') {{
					if (maze[!tc][tx][ty] == 'P') {
						if (ts <= T) { cout << "YES" << endl;return; }
					}
					q.push(Node(!tc, tx, ty, ts));
					vis[tc][tx][ty] = 1;
					vis[!tc][tx][ty] = 1;
				}	
			}
			if (maze[tc][tx][ty] == 'P') {
				if (ts <= T) {
					cout << "YES" << endl; return;
				}
			}
		}
	}
	cout << "NO" << endl;
}
int main() {
	int t;
	cin >> t;
	while (t--)
	{
		memset(vis, 0, sizeof(vis));
		cin >> N >> M >> T;
		for (int i = 0; i < 2; i++) {
			for (int j = 0; j < N; j++) {
				for (int k = 0; k < M; k++) {
					cin >> maze[i][j][k];
				}
			}
		}
		vis[0][0][0] = 1;
		BFS();
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值