八数码:
题目描述:
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x
where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->
The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
Input:
You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8
Output:
You will print to standard output either the word ``unsolvable’’, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.。
Sample Input:
2 3 4 1 5 x 7 6 8
Sample Output:
ullddrurdllurdruldr
题目大意:
其实这道题很简单理解,就是简单的九宫格排序问题,而只能移动上下左右这四个方向,并且还要满足1 2 3 4 5 6 7 8 x这样的排序即可.
思路分析:
这道题有许多解法,有兴趣可以在我博客找到相关解法,我们在这里讲一下DFS解法。
1. 判断条件:用康托定理(哈希)来判断所有数字是否达到目
标状态。
2. 递归条件:因为在九宫格内,只能在当前位置每次只能移动
上下左右其中一个方向。
3. 回溯判断:用一个visit数组标记当前状态是否走过,以及
该递归的这条路结果如果没达到目标状态,就回溯。
4. 剪枝:这里需要判断上次所走的方向与当前所走的方向是否
相反,如果相反,相当于做了无用功。
5. 相关操作:用一个数据结构储存x的位置以及状态以及所要
操作的数字数组,用一个字符数组记录方向,用depth来表示
所递归的深度,用visit数组来标记状态是否经过。
代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
using namespace std;
int fc[]={1,1,2,6,24,120,720,5040,40320,362880};//1~9的阶乘
int di1[5][2]={{1,0},{-1,0},{0,1},{0,-1}};//方向操作变量
char di2[5]={"durl"};//方向操作符号
int visit[363000]; //记录状态
char c1[100];//记录方向操作符号
typedef struct Lemon
{
int s[9];//记录数字
int loc;//记录x的位置
int num;//记录状态
}Lemon;
int Hash(int s[])//康拖定理正向解码
{
int sum=1;
for(int i=0;i<9;i++)
{
int num=0;
for(int j=i;j<9;j++)
{
if(s[j]<s[i])
{
num++;
}
}
sum+=fc[8-i]*num;
}
return sum;
}
int LemonDFS(Lemon now,int pre,int depth)//pre是记录上次方向,防止做无用功,depth为深度
{
if(now.num==1)//因123456789 的Hash值为1
{
c1[depth]='\0';
puts(c1);
return 1;
}
int x1=now.loc/3;
int y1=now.loc%3;
for(int i=0;i<4;i++)
{
if(pre+i==1 || pre+i==5)continue;//判断是否走回原处
int x=x1+di1[i][0];
int y=y1+di1[i][1];
if(x<0 || y<0 || x>2 || y>2)continue;//判断边界
else
{
Lemon next=now;
next.loc=x*3+y;
next.s[now.loc]=next.s[next.loc];
next.s[next.loc]=9;
//交换2个板块的值
next.num=Hash(next.s);//记录Hash值
c1[depth]=di2[i];//记录符号
if(!visit[next.num])//判断该Hash(状态)是否走过
{
visit[next.num]=1;//标记
if(LemonDFS(next,i,depth+1))//递归
{
return 1;
}
}
}
}
return 0;
}
int main()
{
Lemon Frist;
char c1;
for(int i=0;i<9;i++)//记录字符
{
cin >> c1;
if(c1=='x')
{
Frist.s[i]=9;
Frist.loc=i;
}
else
{
Frist.s[i]=c1-'0';
}
}
Frist.num=Hash(Frist.s);
visit[Frist.num]=1;
if(!LemonDFS(Frist,1000,0))//DFS开始
{
cout << "unsolveable" << endl;
}
}