串的模式匹配-KMP算法


                         Number Sequence                              

                                Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
 
 
213 51 2 1 2 3 1 2 3 1 3 2 1 21 2 3 1 313 51 2 1 2 3 1 2 3 1 3 2 1 21 2 3 2 1
 
Sample Output
 
 
6-1


串的模式匹配:设有两个字符串 S 和 T ,设 S 为主串,也称正文串;设 T 为子串,也称为模式。在主串 S 中查找与模式 T 相匹配的子串,如果匹配成功,确定相匹配的子串中的第一个字符在主串 S 中出现的位置。

KMP算法相对于BF算法的最大特点是:主串的指针不需要回溯,整个匹配过程中,对主串仅需从头至尾扫描一遍。

next数组解决的问题:当主串中第 i 个字符与模式中第 j 个字符''失配'(即比较不等)时,主串中第 i 个字符(i指针不回溯)应与模式中哪个字符再比较。

最长前缀:以第一个字符开始,但是不包含最后一个字符

next数组:用来保存一个字符串的最长前缀和最长后缀相同的长度,其长度和模式相同。

当匹配失败时,next数组中保存的值决定从模式中哪个字符再次开始比较


加上头文件#include<iostream>报编译错误

#include<cstdio>
#define maxn 1000002
using namespace std;
int a[maxn],b[10002],next[10002];
int n,m;
void cal_next()
{
	next[0]=-1;
	int k=-1,j=0;
	while(j<m)
	{
		if(k==-1||b[k]==b[j])
		{
			k++;j++;
			next[j]=k;
		}else k=next[k];
	}
}
int KMP()
{
	int i=0,j=0;
	while(i<n)
	{
		if(j==-1||a[i]==b[j])
		{i++;j++;}
		else j=next[j];
		if(j==m) return i-m+1;
	}
	return -1;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		for(int i=0;i<m;i++)
		scanf("%d",&b[i]);
		cal_next();
		printf("%d\n",KMP());
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值