10305 - Ordering Tasks-拓扑排序

10305 - Ordering Tasks

 John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task isonly possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containingtwo integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is thenumber of direct precedence relations between tasks. After this, there will be m lines with two integersi and j, representing the fact that task i must be executed before task j.An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4

1 2

2 3

1 3

1 5

0 0

Sample Output

1 4 2 5 3




#include<iostream>
#include<cstring>
using namespace std;
int G[105][105],vis[105];
int n,m,ans[105],k;
void dfs(int v)
{
	vis[v]=-1;
	for(int i=0;i<n;i++)
		if(G[v][i])
		{
			if(vis[i]==-1)//存在环,无解
			return ;
			else if(!vis[i])
			dfs(i);
		}
	vis[v]=1;
	ans[--k]=v;
}
int main()
{
	while(scanf("%d%d",&n,&m)&&n)
	{
		memset(G,0,sizeof(G));
		memset(vis,0,sizeof(vis));
		for(int i=0;i<m;i++)
		{
			int u,v;
			cin>>u>>v;u--,v--;
			G[u][v]=1;
		}
		k=n;
		for(int i=0;i<n;i++)
		 if(!vis[i]) dfs(i);
		for(int i=0;i<n-1;i++)
		cout<<ans[i]+1<<" ";
		cout<<ans[n-1]+1<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值