【动态规划or双指针】PAT 1007 Maximum Subsequence Sum

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

方法一:动态规划

注意,要求的是最小的i和j,所以在更新最大值的时候,只有在>才更新,如果=就不更新。而且用下面的方法求最左边的数的话,如果有前导零,则应该把0也算在序列中。

#include<stdio.h>
#include<vector>
using namespace std;
const int maxn = 1e4+5;
const int inf = 0x3f3f3f3f;
int main(){
    int n;
    vector<int> vt;
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        int d;
        scanf("%d", &d);
        vt.push_back(d);
    }
    int dp[maxn];
    dp[0] = vt[0];
    int res = -inf, l, r;
    for(int i = 1; i < n; i++){
        if(dp[i-1] <= 0){
            dp[i] = vt[i];
        }
        else{
            dp[i] = dp[i-1]+vt[i];
        }
    }
    int index = 0;
    for(int i = 0; i < n; i++){
        if(dp[i] > res){
            res = dp[i];
            index = i;
        }
    }
    if(res < 0){
        printf("0 %d %d", vt[0], vt[n-1]);
        return 0;
    }
    printf("%d", res);
    int tindex = index;
    while(res){
        res -= vt[tindex];
        tindex--;
    }
    while(tindex >= 0 && vt[tindex] == 0) tindex--;
    printf(" %d %d", vt[min(tindex+1, n-1)], vt[index]);

    return 0;
}

方法二:双指针

 注意,赋给sum的初值为-1,而不能是0,因为0也是一个“合法”的最大和,比如如果有一个序列为:-1 0 -2 -3 -4,那么最大和为0,应该输出0 0 0,而如果sum的初值是0的话,那么if(temp > sum)里的代码段将不会被执行,l和r将不会更新,将输出第一个和最后一个数。而如果把if(temp > sum)改为if(temp >= sum),则题目中输出最小的i和j的要求将不能满足。

#include<stdio.h>
using namespace std;
const int maxn = 1e4+5;
int main(){
    int num[maxn];
    int n;
    scanf("%d", &n);
    int l = 0, r = n-1, temp = 0, sum = -1, tempindex = 0;
    for(int i = 0; i < n; i++){
        scanf("%d", num+i);
        temp += num[i];
        if(temp < 0){
            temp = 0;
            tempindex = i+1;
        }
        else{
            if(temp > sum){
                sum = temp;
                r = i;
                l = tempindex;
            }
        }
    }
    if(sum < 0) sum = 0;
    printf("%d %d %d", sum, num[l], num[r]);

    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值