区间素数筛

LightOJ - 1197 

Amakusa, the evil spiritual leader has captured the beautiful princess Nakururu. The reason behind this is he had a little problem with Hanzo Hattori, the best ninja and the love of Nakururu. After hearing the news Hanzo got extremely angry. But he is clever and smart, so, he kept himself cool and made a plan to face Amakusa.

Before reaching Amakusa's castle, Hanzo has to pass some territories. The territories are numbered as a, a+1, a+2, a+3 ... b. But not all the territories are safe for Hanzo because there can be other fighters waiting for him. Actually he is not afraid of them, but as he is facing Amakusa, he has to save his stamina as much as possible.

He calculated that the territories which are primes are safe for him. Now given a and b he needs to know how many territories are safe for him. But he is busy with other plans, so he hired you to solve this small problem!

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case contains a line containing two integers a and b (1 ≤ a ≤ b < 2^31, b - a ≤ 100000).

Output

For each case, print the case number and the number of safe territories.

Sample Input

3

2 36

3 73

3 11

Sample Output

Case 1: 11

Case 2: 20

Case 3: 4

Note

A number is said to be prime if it is divisible by exactly two different integers. So, first few primes are 2, 3, 5, 7, 11, 13, 17, ...

头一开始我的思路就是通过筛选1e5范围内的素数去标记整个区间内的合数,然后通过一边对a到b的查询统计区间内素数的个数

,但是我发现你标记整个区间比较麻烦,无法把较大的a、b映射到一个小的区间内。但后来考虑到了a和b的差最大为1e5,所以我可以把a到b映射到1到1e5。然后统计区间内的素数个数。而且也避免了我当时考虑有的值大的数不能被标记的情况。

代码如下:

#include<bits/stdc++.h>
typedef long long ll;
const ll inf = 1ll<<32;
const ll INF = 1ll<<60;
const int maxn = 1e5+5; 
using namespace std;
int prime[maxn],cnt;
bool vis[maxn];
void init()
{
     cnt=0;
     vis[1]=true;
    for(int i=2;i<maxn;i++)
    {
        if(!vis[i])
        {
            prime[cnt]=i;
            cnt++;
            for(int j=2*i;j<maxn;j+=i)
            vis[j]=true;
        }
    }
}
int main()
{
    int t,ans,a,b;
    ll tmp;
    init();
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        ans=0;
      memset(vis,true,sizeof(vis));
      scanf("%d %d",&a,&b);
      for(int i=0;i<cnt;i++)
      {
        if(1ll*prime[i]*prime[i]>b)
        break;
        if(a/prime[i]<2)
            tmp = 2*prime[i];
        else
           tmp = ((1ll*a-1)/prime[i]+1)*prime[i];
           while(tmp<=b)。
           {
                 vis[tmp-a]=false;
                 tmp+=prime[i];
           }
      }
      for(int i=0;i<=b-a;i++)
      if(vis[i]==true)
      ans++;
      if(a==1)
      ans--;
      printf("Case %d: %d\n",k,ans);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值