Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37522 Accepted: 8341

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
 
 
题目大意  :x轴为海岸线,雷达只能装在海岸线上,小岛在海岸线上面,输入小岛个数、雷达勘测范围。下一行输入N个小岛的坐标。求出最少用几个可以完全勘测到小岛。
 
思路:,贪心,以雷达勘测半径d,以此向x轴画出两条长度d的直线,交X轴分别x[i]与y[i]。如果如图视  第一个y与下一个往后的x都有共同区域 则能公用一个半径为d的雷达。
 
#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
    double x;
    double y;
} p[100000];
int cmp(node a,node b)
{
    return  a.x<b.x;
}
int main()
{
    int n,d,po=0,a[100000],b[100000];
    while(scanf("%d%d",&n,&d)!=EOF &&(n||d))
    {
        if(n!=0&&d!=0)
        {
            po++;
            int sum=1,i;
            for(i=0; i<n; i++)
            {
                scanf("%d%d",&a[i],&b[i]);
                p[i].x=a[i]-sqrt(double(d*d*1.00-b[i]*b[i]*1.00));
                p[i].y=a[i]+sqrt(double(d*d*1.00-b[i]*b[i]*1.00));
            }
            sort(p,p+n,cmp);
            double q=p[0].y;
            int u;
            for(u=1; u<n; u++)
            {
                if(p[u].y<q)
                    q=p[u].y;
                else if(p[u].x>q)
                {
                    sum++;
                    q=p[u].y;
                }
            }
            printf("Case %d: %d\n\n",po,sum);
        }
        else
            break;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值