Pie解题报告

这篇博客详细介绍了如何根据输入的派的数量和朋友数量,以及每个派的半径,来公平地分配派给每个朋友的过程。内容包括样例输入、输出以及相关提示。
摘要由CSDN通过智能技术生成
 

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Hint

注意蛋糕分开必须是同一个蛋糕,不能有不同蛋糕拼成一块新蛋糕.
#include<iostream>
#include<cmath>
using namespace std;
double pi=acos(-1.0); //PI的精确算法。
double a[10005];  //大数组定义在外面好。
int N,F;
bool test(double x) //算法实现函数。
{
   int count=0;
   for(int i=1;i<=N;++i)
   {
	   count+=int(a[i]/x); //一块能分成几块加到count中。
   }
   if(count>=F+1)  //count大于等于 F+1,就是满足条件,继续增大x;
	   return true;
   else
	   return false;

}


int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		double sum = 0;
        double rad; 
		scanf("%d%d",&N,&F);
		for(int i=1;i<=N;i++)
		{
			scanf("%lf",&rad);
			a[i]=rad*rad*pi;
			sum+=a[i];
		}
       double max = sum / ( F + 1 ); //理论上最大的面积(体积)。
       double l = 0.0;
       double r = max;
       double mid = 0.0;

		while(r-l>1e-6) 
		{
			mid=(l+r)/2;
			if(test(mid))
			{
				l=mid;
			}
			else
				r=mid;
		}
		printf("%.4lf\n",mid);
	}
	return 0;
}



FAQ | About Virtual Judge | Contact | Open Source Project
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值