POJ 2771 最大独立集

Guardian of Decency
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 3293 Accepted: 1375

Description

Frank N. Stein is a very conservative high-school teacher. He wants to take some of his students on an excursion, but he is afraid that some of them might become couples. While you can never exclude this possibility, he has made some rules that he thinks indicates a low probability two persons will become a couple:
  • Their height differs by more than 40 cm.
  • They are of the same sex.
  • Their preferred music style is different.
  • Their favourite sport is the same (they are likely to be fans of different teams and that would result in fighting).

So, for any two persons that he brings on the excursion, they must satisfy at least one of the requirements above. Help him find the maximum number of persons he can take, given their vital information.

Input

The first line of the input consists of an integer T ≤ 100 giving the number of test cases. The first line of each test case consists of an integer N ≤ 500 giving the number of pupils. Next there will be one line for each pupil consisting of four space-separated data items:
  • an integer h giving the height in cm;
  • a character 'F' for female or 'M' for male;
  • a string describing the preferred music style;
  • a string with the name of the favourite sport.

No string in the input will contain more than 100 characters, nor will any string contain any whitespace.

Output

For each test case in the input there should be one line with an integer giving the maximum number of eligible pupils.

Sample Input

2
4
35 M classicism programming
0 M baroque skiing
43 M baroque chess
30 F baroque soccer
8
27 M romance programming
194 F baroque programming
67 M baroque ping-pong
51 M classicism programming
80 M classicism Paintball
35 M baroque ping-pong
39 F romance ping-pong
110 M romance Paintball

Sample Output

3
7

Source

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>

using namespace std;

struct person
{
	char sex[5];
	char music[101];
	char phy[101];
	int high;
};

person male[505],female[505];
int map[505][505];
int link[505];
bool used[505];
int n,num1,num2;

bool judge(person a,person b)
{
	if(abs(a.high-b.high)>40)
		return false;
	if(strcmp(a.sex,b.sex)==0)
		return false;
	if(strcmp(a.music,b.music)!=0)
		return false;
	if(strcmp(a.phy,b.phy)==0)
		return false;
	return true;
}

bool dfs(int v)
{
	int i,p;
	for(i=0;i<num2;i++)
	{
		if(map[v][i]==true&&!used[i])
		{
			used[i]=true;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=v;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	int t,i,j,ans;
	person stu;
	scanf("%d",&t);
	while(t--)
	{
		ans=0;
		num1=0;
		num2=0;
		memset(map,0,sizeof(map));
		memset(link,-1,sizeof(link));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%s%s%s",&stu.high,stu.sex,stu.music,stu.phy);
			if(strcmp(stu.sex,"M")==0)
				male[num1++]=stu;
			if(strcmp(stu.sex,"F")==0)
				female[num2++]=stu;
		}
		for(i=0;i<num1;i++)	
			for(j=0;j<num2;j++)
			{
				if(judge(male[i],female[j]))
				{
					map[i][j]=true;
				}
			}
		for(i=0;i<num1;i++)
		{
			memset(used,0,sizeof(used));
			if(dfs(i))
				ans++;
		}
		printf("%d/n",n-ans);
	}	
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值