POJ 3468 线段树,OIer杨弋出的题目。。膜拜中。。。orz...

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 17755 Accepted: 4605
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

#include<stdio.h>
#include<string.h>

struct node
{
	__int64 l;
	__int64 r;
	__int64 d;
	__int64 val;
};
node tree[400000];
__int64 num[100005],sum;

void build(__int64 l,__int64 r,__int64 root)
{
	tree[root].l=l;
	tree[root].r=r;
	if(l==r)
	{
		tree[root].val=num[l];
		tree[root].d=0;
		return;
	}
	__int64 mid=(l+r)>>1;
	build(l,mid,root*2);
	build(mid+1,r,root*2+1);
	tree[root].val=tree[root*2].val+tree[root*2+1].val;
	tree[root].d=0;
}

void findsum(__int64 l,__int64 r,__int64 root)
{
	if(tree[root].l==l&&tree[root].r==r)
	{
		sum=sum+tree[root].val;
		return;
	}
	sum=sum+(r-l+1)*tree[root].d;
	__int64 mid=(tree[root].l+tree[root].r)>>1;
	if(mid>=r)
		findsum(l,r,root*2);
	else if(mid<l)
		findsum(l,r,root*2+1);
	else
	{
		findsum(l,mid,root*2);
		findsum(mid+1,r,root*2+1);
	}
}

void update(__int64 l,__int64 r,__int64 c,__int64 root)
{
	tree[root].val=tree[root].val+((r-l+1)*c);
	if(tree[root].l==l&&tree[root].r==r)
	{
		tree[root].d=tree[root].d+c;
		return;
	}
	__int64 mid=(tree[root].l+tree[root].r)>>1;
	if(mid>=r)
		update(l,r,c,root*2);
	else if(mid<l)
		update(l,r,c,root*2+1);
	else
	{
		update(l,mid,c,root*2);
		update(mid+1,r,c,root*2+1);
	}
}

int main()
{
	__int64 i,n,Q,a,b,c;
	char ch[2];
	scanf("%I64d%I64d",&n,&Q);
	for(i=1;i<=n;i++)
		scanf("%I64d",&num[i]);
	build(1,n,1);
	while(Q--)
	{
		scanf("%s",ch);
		if(ch[0]=='Q')
		{
			sum=0;
			scanf("%I64d%I64d",&a,&b);
			findsum(a,b,1);
			printf("%I64d/n",sum);
		}
		if(ch[0]=='C')
		{
			scanf("%I64d%I64d%I64d",&a,&b,&c);
			update(a,b,c,1);
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值