HDU/HDOJ 1396 浙大月赛2003年

Counting Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1160    Accepted Submission(s): 573


Problem Description
Given an equilateral triangle with n the length of its side, program to count how many triangles in it.



 

Input
The length n (n <= 500) of the equilateral triangle's side, one per line.

process to the end of the file
 

Output
The number of triangles in the equilateral triangle, one per line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 5 13
 

Author
JIANG, Jiefeng
 

Source
 

我是这样思考的。

可以看出来,边长+1意味着三角形多了一行

那么可以针对多的那一行做特殊计算,因为上一次边长的三角形是没有变化的!

经过非常穷凶极恶的公式推导终于得到了最后的答案


我的代码:

#include<stdio.h>

int ans[505];

int cal(int n)
{
	int t1,t2,t3;
	t1=2*n-1;
	t2=(n-1)*n/2;
	if(n&1)
		t3=(n-1)*(n-3)/4;
	else
		t3=(n-2)*(n-2)/4;
	return t1+t2+t3;
}

void init()
{
	int i;
	ans[1]=1;
	for(i=2;i<=500;i++)
		ans[i]=ans[i-1]+cal(i);
}

int main()
{
	int n;
	init();
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",ans[n]);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值