HDU/HDOJ 2854 2009 Multi-University Training Contest 5 - Host by NUDT 数论

 

Central Meridian Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 210    Accepted Submission(s): 117


Problem Description
A Central Meridian (ACM) Number N is a positive integer satisfies that given two positive integers A and B, and among A, B and N, we have
N | ((A^2)*B+1) Then N | (A^2+B)
Now, here is a number x, you need to tell me if it is ACM number or not.
 

Input
The first line there is a number T (0<T<5000), denoting the test case number.
The following T lines for each line there is a positive number N (0<N<5000) you need to judge.
 

Output
For each case, output “YES” if the given number is Kitty Number, “NO” if it is not.
 

Sample Input
  
  
2 3 7
 

Sample Output
  
  
YES NO
Hint
Hint X | Y means X is a factor of Y, for example 3 | 9; X^2 means X multiplies itself, for example 3^2 = 9; X*Y means X multiplies Y, for example 3*3 = 9.
 

Source
 
其实是标题党。。
这货就是预处理一下就可以了。。纯暴力
 
我的代码:
#include<stdio.h>

bool flag[5005];

void init()
{
	int i,j,n,x,y;
	for(n=1;n<=5000;n++)
	{
		for(i=1;i<=1000;i++)
		{
			for(j=1;j<=1000;j++)
			{
				x=i*i*j+1;
				y=i*i+j;
				if(x%n==0)
				{
					if(y%n!=0)
					{
						flag[n]=true;
						goto loop;
					}
				}
			}
		}
		loop:;
	}
}

int main()
{
	int n,t;
	init();
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		if(flag[n])
			printf("NO\n");
		else
			printf("YES\n");
	}
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值