A Simple Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)Total Submission(s): 474 Accepted Submission(s): 142
Problem Description
For a given positive integer n, please find the smallest positive integer x that we can find an integer y such that y^2 = n +x^2.
Input
The first line is an integer T, which is the the number of cases.
Then T line followed each containing an integer n (1<=n <= 10^9).
Then T line followed each containing an integer n (1<=n <= 10^9).
Output
For each integer n, please print output the x in a single line, if x does not exit , print -1 instead.
Sample Input
2 2 3
Sample Output
-1 1
Author
HIT
Source
Recommend
lcy
解法:
x^2+n=y^2
n=y^2-x^2=(y-x)*(y+x)
所以,可以枚举y-x的值来确定y+x
然后通过不断更新x的值来获得最小的ans
我的代码:
import java.math.*;
import java.io.*;
import java.util.*;
public class Main {
public static void main(String arg[])
{
Scanner cin=new Scanner(System.in);
int t,T,n,i,ans;
int a,b,x,y;
T=cin.nextInt();
for(t=1;t<=T;t++)
{
n=cin.nextInt();
ans=1999999999;
for(i=1;i*i<=n;i++)
{
if(n%i==0)
{
a=i;
b=n/i;
if(b-a>0)
{
if((a+b)%2==0)
{
if((b-a)%2==0)
{
x=(b-a)/2;
y=(a+b)/2;
if(x<ans)
ans=x;
}
}
}
}
}
if(ans>=1999999999)
System.out.println("-1");
else
System.out.println(ans);
}
}
}