TensorFlow中报错 module 'tensorflow_core._api.v2.train' has no attribute 'GradientDescentOptimize

原来函数是这样写的:

optimizer = tf.train.GradientDescentOptimizer

报错: AttributeError: module 'tensorflow_core._api.v2.train' has no attribute 'GradientDescentOptimizer'

此时应改为:

optimizer = tf.compat.v1.train.GradientDescentOptimizer

就可以啦

发布了136 篇原创文章 · 获赞 48 · 访问量 3万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 技术工厂 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览