UVa11567 - Moliu Number Generator(记忆化搜索dfs)

ProblemC: Moliu Number Generator

Let's play a number game. We start with N = 0, and we want to make N = a given integer S.

Only three types of operations are allowed:

  1. INC : increment N by 1, i.e. N <-- N + 1
  2. DEC : decrement N by 1, i.e. N <-- N - 1
  3. DBL : double N, i.e. N <-- 2 N

Of course we want to make N = S with the minimum number of operations. Consider an example: Let S = 7. Then only 5 steps are required, for instance:

  1. INC : N = 0 + 1 = 1
  2. INC : N = 1 + 1 = 2
  3. DBL : N = 2 × 2 = 4
  4. DBL : N = 2 × 4 = 8
  5. DEC : N = 8 - 1 = 7 <-- DONE!!

Input

Input contains no more than 200 lines. Each line contains one integer S (0 ≤ S ≤ 231). Input is terminated by EOF.

Output

For each S, output the minimum number of operations required to make N = S. You may assume that N is of infinite precision, so NO overflow will ever occur.

Sample Input

7

Sample Output

5

记忆化搜索

#include <cstdio>
#include <algorithm>
#include <map>

using namespace std;

long long n;
map<long long, int> m;

bool input();
void solve();
int f(long long n);

int main()
{
	#ifndef ONLINE_JUDGE
		freopen("d:\\OJ\\uva_in.txt", "r", stdin);
	#endif

	while (input()) {
		solve();
	}
	return 0;
}

bool input()
{
	return scanf("%lld", &n) == 1;
}

int f(long long n)
{
	if (m.count(n)) return m[n];
	
	if (n == 0) return 0;
	
	if (n == 1) return 1;
	
	if (!(n & 1)) return m[n] = f(n / 2) + 1;
	else {
		return m[n] = min(f(n + 1), f(n - 1)) + 1;
	}
}

void solve()
{
	printf("%d\n", f(n));
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值