HDU-2669 Romantic (欧几里得定理)

HDU-2669 Romantic (欧几里得定理)

 

The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.


Input The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

#include<cstdio>
int x,y;
int gcd(int a,int b)
{   
       int t,d;    
       if(b==0)   
       {
         x=1;       // 由扩展欧几里得定理:ax+by==gcd(a,b)
                   //而此时b==0,gcd(a,0)==a。
                  //原式变为ax+by==a --> x==1
         y=0;
         return a;
       }
      d=gcd(b,a%b);//递归到头,回溯才做x,y的变化。
      t=x;         //ax+by=k*gcd(a,b)=k*gcd(b,a%b)=bx+(a%b)y=g,实际上是a,b的变化引起x,y的变化。第一个为x1,y1,第二个
                   //为x2,y2. (x1,y1)=(y2,x2-a/b*y2)
      x=y;         //bx+(a%b)y=bx+(a-a/b*b)y=ay+b(x-a/b*y)=g
      y=t-(a/b)*y; //所以利用递归就能求出原解。
      return d;//没有return递归就不能进行 毕竟x,y是要不断变化的,d当然是都一样的,毕竟是最大公约数。
}
int main()
{   
   int a,b;
   while(scanf("%d%d",&a,&b)!=EOF)
   {
     int d=gcd(a,b);
     if(d!=1)  
    {  
        printf("sorry\n");  
        continue;          //1是g,g必须是gcd(a,b)的倍数,所以a,b的最大公约数必须是1,
    }  
     else
    {    
           while(x<=0)  
        {  
            x=x+b; //b==b/g*t,因为g==1
            y=y-a;  
        }  
         printf("%d %d\n",x,y);
     }
   }
   return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值