HDU-1518 Square(深搜)

HDU-1518 Square(深搜)

 

        Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes
#include<cstdio> 
#include<iostream>  
#include<cstring>  
#include<algorithm>  
using namespace std;  
int a[25];  
int n,aver;  
int flag;  
int book[25];  
void dfs(int num,int len,int start) 
{  
    if(flag)  
    return;  
    if(num==4)  //想要一找到就结束,所有地方都加return就行了 
    {  
      flag=1;  
      return;  
    }  
    if(len==aver)  
    {  
        dfs(num+1,0,0);  
        if(flag)  
        return;  
    }  
    for(int i=start;i<n;i++)  
    {                          
        if(book[i]==0&&len+a[i]<=aver)  
        {  
            book[i]=1;  
            dfs(num,len+a[i],i+1);  
            book[i]=0;  
            if(flag)  
            return;  
        }  
    }  
}  
int main()  
{  
    int t,i;  
    scanf("%d",&t);  
    while(t--)  
    {  
      scanf("%d",&n);
      int sum=0;
	  int max=0;  
      for(i=0;i<n;i++)  
      {  
        scanf("%d",&a[i]);
        sum+=a[i];  
        if(a[i]>max)  
         max=a[i];  
      }  
        aver=sum/4;  
     if(sum%4!=0||max>aver)  
    {  
        printf("no\n");
        continue;  
    }  
        sort(a,a+n);  
        memset(book,0,sizeof(book));  
        flag=0;  
        dfs(0,0,0);  
        if(flag)  
        printf("yes\n");
        else  
        printf("no\n");
    }  
        return 0;  
}  

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值