poj1042

6 篇文章 0 订阅
2 篇文章 0 订阅
Gone Fishing
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 25876 Accepted: 7615
Description


John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. 
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.
Input


You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.
Output


For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. 
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.
Sample Input




10 1 
2 5 



10 15 20 17 
0 3 4 3 
1 2 3 


10 15 50 30 
0 3 4 3 
1 2 3 

Sample Output


45, 5 
Number of fish expected: 31 


240, 0, 0, 0 
Number of fish expected: 480 


115, 10, 50, 35 

Number of fish expected: 724 

分析:采用贪心的方法,需要思索一番,找到贪心的条件,即以逐步增加钓鱼的湖数为贪心条件,这样就可以假设在任何时间,他可以移动到任何想去的湖,而移动的过程无需时间。只需在每个5分钟的开始“瞬间移动”到当前5分钟中能钓到最多的鱼的湖中,且只钓5分钟的鱼。这样逐步积累,等到时间耗尽时,就得到一次贪心条件下的最大钓鱼数。最后,贪心完成,得到最大钓鱼数。

代码:

#include<iostream>
using namespace std;
struct get_fish
{
	int fish_num;//5分钟可以钓到的鱼数
	int dis;//5分钟钓鱼数的减少量
	int count;//记录每个湖的钓鱼时间
}fish[26],fish1[26];
int get_max(get_fish a[],int n)
{
	int max=1;
	for(int i=2;i<=n;i++)
	{
		if(a[max].fish_num<a[i].fish_num)
			max=i;
	}
	if(a[max].fish_num==0)
		max=1;
	//cout<<"m="<<max<<"\tmax="<<a[max].fish_num<<"\t";
	return max;
}
int cost[26];//第i个湖到第i+1个湖的时间
int main()
{
	int n;//n个湖
	int h;//h个小时
	int temp=0;
	while(cin>>n&&n)
	{
		temp++;
		cin>>h;
		int time=h*12;//小时换算为若干个5分钟
		int i,sum_fish=0;
		for(i=1;i<=n;i++)
			cin>>fish[i].fish_num;
		for(i=1;i<=n;i++)
			cin>>fish[i].dis;
		for(i=1;i<n;i++)
			cin>>cost[i];
		for(int m=1;m<=n;m++)//钓完前m个湖
		{
			int temp_time=time;
			for(i=1;i<=n;i++)
			{
				fish1[i].fish_num=fish[i].fish_num;
				fish1[i].dis=fish[i].dis;
				fish1[i].count=0;
			}
			//cout<<"m="<<m<<endl;
			int temp_fish=0;
			int fish_lake=0;//在哪个湖钓鱼
			for(i=1;i<m;i++)//总时间减去钓完前m个湖在路途中花费的时间
				temp_time=temp_time-cost[i];
			//cout<<"time0="<<temp_time<<endl;
			for(i=temp_time;i>0;i--)//时间逐步减少,直至时间耗尽
			{
				//cout<<"time="<<i<<"\t";
				fish_lake=get_max(fish1,m);//得到当前最大钓鱼数
				temp_fish=temp_fish+fish1[fish_lake].fish_num;
				//cout<<"temp_fish="<<temp_fish<<endl;
				fish1[fish_lake].fish_num=fish1[fish_lake].fish_num-fish1[fish_lake].dis;//减少下个5分钟钓的鱼数
				fish1[fish_lake].count++;//记录钓鱼次数
				if(fish1[fish_lake].fish_num<0)//钓鱼数不能为负数
					fish1[fish_lake].fish_num=0;
			}
			if(temp_fish>sum_fish)
			{
				for(i=1;i<=n;i++)
					fish[i].count=fish1[i].count;
				sum_fish=temp_fish;
			}
			//cout<<"temp_fish="<<temp_fish<<endl;
		}
		for(i=1;i<=n-1;i++)
		{
				cout<<fish[i].count*5<<", ";
		}
		cout<<fish[n].count*5<<endl;
		cout<<"Number of fish expected: "<<sum_fish<<endl<<endl;
	}
	return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值