poj 3026 Borg Maze 【prim+bfs】

Borg Maze
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13945 Accepted: 4550

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance.

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11

AC代码:

# include <stdio.h>
# include <string.h>
# include <queue>

using namespace std;

# define INF 10000000
# define M 105

struct Point
{
	int x;
	int y;
}; 

Point point[M]; //记录S和A的位置,并对他们进行编号
char str[M][M]; //用于记录输入的字符信息
int pNum;       //统计S和A的数目,方便最小生成树的构建
int row, col;
int map[M][M];
int next[4][2] = {	 //方向数组,用于宽搜时向四个方向进行遍历
	{0, 1},					
	{1, 0}, 			
	{0, -1}, 
	{-1, 0}
};

void FindPoint()
{
	pNum = 1;
	for (int i = 0; i < row; i++)
	{
		for (int j = 0; j < col; j++)
		{
			if (str[i][j] == 'A')
			{
				point[pNum].x = i;
				point[pNum].y = j;
				pNum ++;
			}
			else if (str[i][j] == 'S')
			{
				point[0].x = i;
				point[0].y = j;
			}
		}
	}
}

void bfs(int start) //用于所有符合点之间的距离
{
	int book[M][M]; //标记地图上的点是否已访问
	int dist[M][M]; //记录两个点的距离
	queue <int> que;
	int i, j, x, y, tx, ty;

	for (i = 0; i < row; i++)
	{
		for (j = 0; j < col; j++)
		{
			book[i][j] = 0;
			dist[i][j] = 0;
		}
	}
	x = point[start].x;
	y = point[start].y;
	que.push(x);
	que.push(y);
	book[x][y] = 1;

	while (!que.empty())
	{
		x = que.front();
		que.pop();
		y = que.front();
		que.pop();
		for (i = 0; i < 4; i++)
		{
			tx = x + next[i][0];
			ty = y + next[i][1];
			if ( tx < 0 || tx >= row || ty < 0 || ty >= col)
			{
				continue;
			}
			if (!book[tx][ty] && str[tx][ty] != '#')
			{
				book[tx][ty] = 1;
				dist[tx][ty] = dist[x][y] + 1;
				que.push(tx);
				que.push(ty);
			}
		}
	}
	for (i = 0; i < pNum; i++)
	{
		int t = dist[point[i].x][point[i].y];
		if (t)
		{
			map[start][i] = t; //装换成通常的二维数组,用于求最小生成树
		}
	}
}

void Prim()
{
	int i, j, k;
	int lowcost[M],mincost;
	int vis[M];
	for (i = 0; i < pNum; i++)
	{
		lowcost[i] = map[0][i];
		vis[i] = 0;
	}

	vis[0] = 1;
	int sum = 0;
	for (i = 0; i < pNum; i++)
	{
		mincost = INF;
		k = -1;
		for (j = 0; j < pNum; j++)
		{
			if (!vis[j] && lowcost[j] < mincost)
			{
				mincost = lowcost[j];
				k = j;
			}
		}
		if (-1 == k)
		{
			break;
		}
		sum += mincost;
		vis[k] = 1;
		for (j = 0; j < pNum; j++)
		{
			if (!vis[j] && map[k][j] < lowcost[j])
			{
				lowcost[j] = map[k][j];
			}
		}
	}  
    printf("%d\n", sum);  
}

int main(void)
{
	int t, i;

	scanf("%d", &t);
	while (t--)
	{
		scanf("%d %d", &col, &row);
		char temp[51];
		gets(temp); //这儿不能使用getchar();不然会一直wa,我检查了好多次,提交了好多次,都快崩溃啦
	
		for (i = 0; i < row; i++)
		{
			gets(str[i]);
		}
		FindPoint();
		for (i = 0; i < pNum; i++)
		{
			bfs(i);
		}
		Prim();
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值