android studio编译出错——Failed to resolve: com.android.support:support-v4:22.2.0

原创 2015年08月04日 10:19:23

解决问题两种方式:

第一种:检查版本:platform-tools为22,support library为22, support repository为最新即可



第二种:自己添加jar包

1.首先查看类库libs文件夹下是否有android-support-v4.jar,如果没有,添加进来。


2.打开flle——project structure——dependencies,看看support-v4如图显示 ,右键remove



3.然后从libs下把support-v4加进来: 点击加号——点击2



4. 然后会看到被正常引入,点击apply——稍等——点击ok


Android Studio强者之路

Google为Android Developer量身定做的一款IDE,很值得大家去学习,而本系列视频从浅到深,一步步带领大家完全掌握这款工具的使用!
  • 2016年07月31日 11:35

Could not find com.android.support:support-v4:26.0.2

整个项目都没有使用26.0.2版本的内容,却报如下错误:Error:Could not find com.android.support:support-v4:26.0.2. Required by:...
  • liuzhenlee
  • liuzhenlee
  • 2017-09-25 22:30:25
  • 2795

Failed to resolve: com.android.support:support-v4:23.1.1

完整错误信息如下: Failed to resolve: com.android.support:support-v4:23.1.1 Install Repository and sync pro...
  • u010884814
  • u010884814
  • 2016-01-06 10:07:19
  • 4606

Error:(24, 13) Failed to resolve: com.android.support:recyclerview-v7:20.+ <a href="install.m2.repo"

Android studio   报错    Error:(24, 13) Failed to resolve: com.android.support:recyclerview-v7:20.+ I...
  • u012303938
  • u012303938
  • 2015-07-07 10:04:34
  • 24419

Failed to resolve: com.android.support:support-v4:19

通过Android Studio打开工程时报错“Failed to resolve: com.android.support:support-v4:19” 是Android Studio中的Supp...
  • huluobobb
  • huluobobb
  • 2015-08-25 17:31:45
  • 2126

Failed to resolve: com.android.support:appcompat-v7:27.0.1问题解决

Failed to resolve: com.android.support:appcompat-v7:27.0.1问题解决
  • waa_studio
  • waa_studio
  • 2017-12-06 16:55:18
  • 10983

Android Studio 错误Error:(16, 13) Failed to resolve: com.android.support:support-v4:15.+ android.vi

错误1: Error:(16, 13) Failed to resolve: com.android.support:support-v4:15.+ Install Repository and ...
  • Tom_xiaoxie
  • Tom_xiaoxie
  • 2015-12-04 08:38:39
  • 5681

(问题记录)Failed to resolve: com.android.support:support-v4:23.1.1

Failed to resolve: com.android.support:support-v4:23.1.1Install Repository and sync project Show in ...
  • yimowunai
  • yimowunai
  • 2016-04-01 09:45:21
  • 853

android studio " Could not resolve com.android.support:appcompat-v7:26.1.0"

在Android  studio 3.0 的新工程依赖 “ com.android.support:design:26.1.0” 时,sync错误,报以下问题:    Unable to res...
  • qq_26984087
  • qq_26984087
  • 2017-11-13 11:16:00
  • 1288

Android Support 库 24.2.0 正式发布

技术鸟 2016-08-20 08:48 近日,Google正式发布更新了Android Support Library Revision 24.2.0 版本。这次更新绝对满足了每一位 ...
  • u011277123
  • u011277123
  • 2016-08-26 11:06:43
  • 4723
收藏助手
不良信息举报
您举报文章:android studio编译出错——Failed to resolve: com.android.support:support-v4:22.2.0
举报原因:
原因补充:

(最多只允许输入30个字)